summary refs log tree commit diff
path: root/gnu/packages/text-editors.scm
diff options
context:
space:
mode:
authorng0 <ng0@infotropique.org>2017-07-26 14:24:56 +0000
committerLudovic Courtès <ludo@gnu.org>2017-07-26 23:13:52 +0200
commit217ce5702cde1543cfc56727c1ca3bb3f9dbc5a5 (patch)
tree20f0ef550f23724cd5ba655c29a16714423fec37 /gnu/packages/text-editors.scm
parentbcd1544dd27a17fd554e297cd8672231d7488c98 (diff)
downloadguix-217ce5702cde1543cfc56727c1ca3bb3f9dbc5a5.tar.gz
gnu: mg: Add new phase to find 'diff'.
* gnu/packages/text-editors.scm (mg)[phases]: Add new 'correct-location-of-difftool'.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/text-editors.scm')
-rw-r--r--gnu/packages/text-editors.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index 7357df7fb3..7843c120aa 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -261,6 +261,12 @@ Wordstar-, EMACS-, Pico, Nedit or vi-like key bindings.  e3 can be used on
                           "CC=gcc")
        #:phases (modify-phases %standard-phases
                   (delete 'configure)
+                  (add-before 'build 'correct-location-of-difftool
+                    (lambda _
+                      (substitute* "buffer.c"
+                        (("/usr/bin/diff")
+                         (which "diff")))
+                      #t))
                   (add-before 'install 'patch-tutorial-location
                     (lambda* (#:key outputs #:allow-other-keys)
                       (substitute* "mg.1"