summary refs log tree commit diff
path: root/gnu/packages/textutils.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-04-09 17:01:16 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-09 17:14:52 +0100
commit9a4c57f55f644ccd52d0d810f1db04f8c85ad8b9 (patch)
tree9afd65111328c5e4d1e1937f444594fd94f53b6f /gnu/packages/textutils.scm
parenteed3fcceed0a62838fa927275e7867a3e4c3d2d8 (diff)
downloadguix-9a4c57f55f644ccd52d0d810f1db04f8c85ad8b9.tar.gz
gnu: vale: Unbundle more packages.
* gnu/packages/textutils.scm (vale):
[source]: Remove more vendored modules.
[native-inputs]: Add go-github-com-fatih-color, go-github-com-gobwas-glob,
go-github-com-mitchellh-go-homedir, go-github-com-yuin-goldmark,
go-golang-org-x-net-html, go-gopkg-in-ini-v1, and
go-gopkg-in-yaml-v2.

Change-Id: Ia7e87888fd286b54157382d01c8a3ca8475e3cb0
Diffstat (limited to 'gnu/packages/textutils.scm')
-rw-r--r--gnu/packages/textutils.scm27
1 files changed, 22 insertions, 5 deletions
diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index 02a75a0aba..38452339c0 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -1435,24 +1435,41 @@ of a Unix terminal to HTML code.")
         (base32 "0d07fwha2220m8j24h527xl0gnl3svvyaywflgk5292d6g49ach2"))
        (file-name (git-file-name name version))
        (modules '((guix build utils)))
-       ;; Remove some vendor modules.
+       ;; Remove some available vendor modules.
        ;; TODO: Pack all of them and remove vendor directory completely.
        (snippet
         '(for-each
           delete-file-recursively
-          (list "vendor/github.com/mitchellh/mapstructure"
+          (list "vendor/github.com/fatih/color"
+                "vendor/github.com/mitchellh/mapstructure"
+                "vendor/github.com/gobwas/glob"
+                "vendor/github.com/mitchellh/go-homedir"
                 "vendor/github.com/olekukonko/tablewriter"
                 "vendor/github.com/spf13/afero"
-                "vendor/github.com/urfave/cli")))))
+                "vendor/github.com/urfave/cli"
+                "vendor/github.com/yuin/goldmark"
+                "vendor/golang.org/x/net/html"
+                "vendor/gopkg.in/ini.v1"
+                "vendor/gopkg.in/yaml.v2")))))
     (build-system go-build-system)
     (arguments
      (list #:install-source? #f
            #:import-path "github.com/errata-ai/vale"))
     (native-inputs
-     (list go-github-com-mitchellh-mapstructure
+     (list go-github-com-fatih-color
+           go-github-com-mitchellh-mapstructure
+           go-github-com-gobwas-glob
+           ;; go-github-com-jdkato-prose
+           ;; go-github-com-jdkato-regexp
+           go-github-com-mitchellh-go-homedir
            go-github-com-olekukonko-tablewriter
+           ;; go-github-com-remeh-sizedwaitgroup
            go-github-com-spf13-afero
-           go-github-com-urfave-cli))
+           go-github-com-urfave-cli
+           go-github-com-yuin-goldmark
+           go-golang-org-x-net-html
+           go-gopkg-in-ini-v1
+           go-gopkg-in-yaml-v2))
     (home-page "https://github.com/errata-ai/vale")
     (synopsis "Fully customizable syntax-aware linter that focuses on your style")
     (description