summary refs log tree commit diff
path: root/gnu/packages/textutils.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2017-02-10 23:18:49 -0600
committerEric Bavier <bavier@member.fsf.org>2017-02-13 20:59:25 -0600
commit5353cea007e72dba27ddd2cc02a37180dedec97c (patch)
tree47d1d6a26416c83cbb75fe52c8cb36e180b665c7 /gnu/packages/textutils.scm
parent5d230d5b4628d79481cb77ce03a12aeae19a842b (diff)
downloadguix-5353cea007e72dba27ddd2cc02a37180dedec97c.tar.gz
gnu: utf8proc: Enable tests.
* gnu/packages/textutils.scm (utf8proc)[inputs]: New field.
[arguments]: Remove '#:tests? #f'.  Add check-data phase.
Diffstat (limited to 'gnu/packages/textutils.scm')
-rw-r--r--gnu/packages/textutils.scm30
1 files changed, 27 insertions, 3 deletions
diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index 3d68bb81b4..9e6309a0ed 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -8,6 +8,7 @@
 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2016 ng0 <ng0@we.make.ritual.n0.is>
 ;;; Copyright © 2016 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2017 Eric Bavier <bavier@member.fsf.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -120,13 +121,36 @@ libenca and several charset conversion libraries and tools.")
        (sha256
         (base32 "0q1jhdkk4f9b0zb8s2ql3sba3br5nvjsmbsaybmgj064k9hwbk15"))))
     (build-system gnu-build-system)
+    (inputs                  ;test data that is otherwise downloaded with curl
+     `(("NormalizationTest.txt"
+        ,(origin
+           (method url-fetch)
+           (uri (string-append "http://www.unicode.org/Public/9.0.0/ucd/"
+                               "NormalizationTest.txt"))
+           (sha256
+            (base32 "1fxrz0bilsbwl685336aqi88k62i6nqhm62rvy4zhg3bcm4dhj1d"))))
+       ("GraphemeBreakTest.txt"
+        ,(origin
+           (method url-fetch)
+           (uri (string-append "http://www.unicode.org/Public/9.0.0/ucd/"
+                               "auxiliary/GraphemeBreakTest.txt"))
+           (sha256
+            (base32 "0qbhyhmf0778lc2hcwlpizrvmdxwpk959v2q2wb8abv09ba7wvn7"))))))
     (arguments
-     '(#:tests? #f ;no "check" target
-       #:make-flags (list "CC=gcc"
+     '(#:make-flags (list "CC=gcc"
                           (string-append "prefix=" (assoc-ref %outputs "out")))
        #:phases
        (modify-phases %standard-phases
-         (delete 'configure))))
+         (delete 'configure)
+         (add-before 'check 'check-data
+           (lambda* (#:key inputs #:allow-other-keys)
+             (for-each (lambda (i)
+                         (copy-file (assoc-ref inputs i)
+                                    (string-append "data/" i)))
+                       '("NormalizationTest.txt" "GraphemeBreakTest.txt"))
+             (substitute* "data/GraphemeBreakTest.txt"
+               (("÷") "/")
+               (("×") "+")))))))
     (home-page "http://julialang.org/utf8proc/")
     (synopsis "C library for processing UTF-8 Unicode data")
     (description "utf8proc is a small C library that provides Unicode