summary refs log tree commit diff
path: root/gnu/packages/time.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-01 03:16:15 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:53:56 -0400
commitdd722fc950ab7df501537254d0800c8ecbbd98a5 (patch)
treec7c08b64148691358b5cdf017fb4ef7486759a8f /gnu/packages/time.scm
parentdd915ae36952f31ecf68b9b72c6e630b5abfd75d (diff)
downloadguix-dd722fc950ab7df501537254d0800c8ecbbd98a5.tar.gz
gnu: Remove python2-dateutil.
* gnu/packages/time.scm (python2-dateutil): Delete variable.
Diffstat (limited to 'gnu/packages/time.scm')
-rw-r--r--gnu/packages/time.scm40
1 files changed, 0 insertions, 40 deletions
diff --git a/gnu/packages/time.scm b/gnu/packages/time.scm
index 4ff7b889ac..314ffcc18f 100644
--- a/gnu/packages/time.scm
+++ b/gnu/packages/time.scm
@@ -229,46 +229,6 @@ datetime module, available in Python 2.3+.")
     ;; BSD-3 still; but all new code is dual licensed (the user can choose).
     (license (list bsd-3 asl2.0))))
 
-(define-public python2-dateutil
-  (package
-    (name "python2-dateutil")
-    (version "2.8.2")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (pypi-uri "python-dateutil" version))
-       (sha256
-        (base32
-         "11iy7m4bp2lgfkcl0r6xzf34bvk7ppjmsyn2ygfikbi72v6cl8q1"))))
-    (build-system python-build-system)
-    (arguments
-     `(#:python ,python-2
-       #:phases (modify-phases %standard-phases
-                  (replace 'check
-                    (lambda _
-                      ;; Delete tests that depend on "freezegun" to avoid a
-                      ;; circular dependency.
-                      (delete-file "dateutil/test/test_utils.py")
-                      (delete-file "dateutil/test/test_rrule.py")
-
-                      ;; XXX: Fails to get timezone from /etc/localtime.
-                      (delete-file "dateutil/test/test_tz.py")
-
-                      (invoke "pytest" "-vv"))))))
-    (native-inputs
-     (list python2-pytest python2-pytest-cov python2-setuptools-scm))
-    (propagated-inputs
-     (list python2-six))
-    (home-page "https://dateutil.readthedocs.io/en/stable/")
-    (synopsis "Extensions to the standard datetime module")
-    (description
-     "The dateutil module provides powerful extensions to the standard
-datetime module, available in Python 2.3+.")
-    ;; The license was changed from the three-clause BSD license to a dual
-    ;; Apache 2.0/BSD-3 variant at 2017-12-01.  Some code is only available as
-    ;; BSD-3 still; but all new code is dual licensed (the user can choose).
-    (license (list bsd-3 asl2.0))))
-
 (define-public python-parsedatetime
   (package
     (name "python-parsedatetime")