summary refs log tree commit diff
path: root/gnu/packages/tls.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2018-03-18 02:41:10 +0800
committer宋文武 <iyzsong@member.fsf.org>2018-03-18 02:50:58 +0800
commit5011d3f4a009a8f904444235874edcfbebfa8ac6 (patch)
tree8a145efe24f1bf646d0122fdd93f6cc35974ec8e /gnu/packages/tls.scm
parent8ea5d8685c8ce8fe68f612672d22bf29e28c6ffe (diff)
downloadguix-5011d3f4a009a8f904444235874edcfbebfa8ac6.tar.gz
gnu: openssl: Fix the call of 'apply invoke'.
This fixes the build failure introduced in commit 05f6e6014.

* gnu/packages/tls.scm (openssl, openssl-next)[arguments]: Pass configure
flags to 'apply invoke' as the ARGLIST list.
Diffstat (limited to 'gnu/packages/tls.scm')
-rw-r--r--gnu/packages/tls.scm76
1 files changed, 39 insertions, 37 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 6b1005c2f8..f4a887a233 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -298,24 +298,25 @@ required structures.")
          (lambda* (#:key outputs #:allow-other-keys)
            (let ((out (assoc-ref outputs "out")))
              (apply invoke "./config"
-                    "shared"                   ;build shared libraries
-                    "--libdir=lib"
-
-                    ;; The default for this catch-all directory is
-                    ;; PREFIX/ssl.  Change that to something more
-                    ;; conventional.
-                    (string-append "--openssldir=" out
-                                   "/share/openssl-" ,version)
-
-                    (string-append "--prefix=" out)
-
-                    ;; XXX FIXME: Work around a code generation bug in GCC
-                    ;; 4.9.3 on ARM when compiled with -mfpu=neon.  See:
-                    ;; <https://gcc.gnu.org/bugzilla/show_bug.cgi?id=66917>
-                    ,@(if (and (not (%current-target-system))
-                               (string-prefix? "armhf" (%current-system)))
-                          '("-mfpu=vfpv3")
-                          '())))))
+                    (list
+                     "shared"                 ;build shared libraries
+                     "--libdir=lib"
+
+                     ;; The default for this catch-all directory is
+                     ;; PREFIX/ssl.  Change that to something more
+                     ;; conventional.
+                     (string-append "--openssldir=" out
+                                    "/share/openssl-" ,version)
+
+                     (string-append "--prefix=" out)
+
+                     ;; XXX FIXME: Work around a code generation bug in GCC
+                     ;; 4.9.3 on ARM when compiled with -mfpu=neon.  See:
+                     ;; <https://gcc.gnu.org/bugzilla/show_bug.cgi?id=66917>
+                     ,@(if (and (not (%current-target-system))
+                                (string-prefix? "armhf" (%current-system)))
+                           '("-mfpu=vfpv3")
+                           '()))))))
         (add-after
          'install 'make-libraries-writable
          (lambda* (#:key outputs #:allow-other-keys)
@@ -422,25 +423,26 @@ required structures.")
                (let* ((out (assoc-ref outputs "out"))
                       (lib (string-append out "/lib")))
                  (apply invoke "./config"
-                        "shared"                   ;build shared libraries
-                        "--libdir=lib"
-
-                        ;; The default for this catch-all directory is
-                        ;; PREFIX/ssl.  Change that to something more
-                        ;; conventional.
-                        (string-append "--openssldir=" out
-                                       "/share/openssl-" ,version)
-
-                        (string-append "--prefix=" out)
-                        (string-append "-Wl,-rpath," lib)
-
-                        ;; XXX FIXME: Work around a code generation bug in GCC
-                        ;; 4.9.3 on ARM when compiled with -mfpu=neon.  See:
-                        ;; <https://gcc.gnu.org/bugzilla/show_bug.cgi?id=66917>
-                        ,@(if (and (not (%current-target-system))
-                                   (string-prefix? "armhf" (%current-system)))
-                              '("-mfpu=vfpv3")
-                              '())))))
+                        (list
+                         "shared"       ;build shared libraries
+                         "--libdir=lib"
+
+                         ;; The default for this catch-all directory is
+                         ;; PREFIX/ssl.  Change that to something more
+                         ;; conventional.
+                         (string-append "--openssldir=" out
+                                        "/share/openssl-" ,version)
+
+                         (string-append "--prefix=" out)
+                         (string-append "-Wl,-rpath," lib)
+
+                         ;; XXX FIXME: Work around a code generation bug in GCC
+                         ;; 4.9.3 on ARM when compiled with -mfpu=neon.  See:
+                         ;; <https://gcc.gnu.org/bugzilla/show_bug.cgi?id=66917>
+                         ,@(if (and (not (%current-target-system))
+                                    (string-prefix? "armhf" (%current-system)))
+                               '("-mfpu=vfpv3")
+                               '()))))))
 
            ;; XXX: Duplicate this phase to make sure 'version' evaluates
            ;; in the current scope and not the inherited one.