summary refs log tree commit diff
path: root/gnu/packages/tls.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-02-09 01:49:08 -0500
committerLeo Famulari <leo@famulari.name>2016-02-12 18:50:32 -0500
commit6cefd53d3e83e7159fca1a0d8653e8cf8b7176fa (patch)
treee0263e103d0cb67e7eef46e2a203e55e959012b1 /gnu/packages/tls.scm
parent8ad4ae204f5205c1335cceff22058411a67392eb (diff)
downloadguix-6cefd53d3e83e7159fca1a0d8653e8cf8b7176fa.tar.gz
gnu: Split acme into python-acme and python2-acme.
* gnu/packages/tls.scm (acme): Split variable into...
(python-acme, python2-acme): ...both Python variants.
(letsencrypt)[propagated-inputs]: Update user of renamed variable.
Diffstat (limited to 'gnu/packages/tls.scm')
-rw-r--r--gnu/packages/tls.scm34
1 files changed, 18 insertions, 16 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index f79db32497..a7945baf10 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -318,9 +318,9 @@ security, and applying best practice development processes.")
                      "file://COPYING"
                      "See COPYING in the distribution.")))))
 
-(define-public acme
+(define-public python-acme
   (package
-    (name "acme")
+    (name "python-acme")
     (version "0.3.0")
     (source (origin
       (method url-fetch)
@@ -330,8 +330,7 @@ security, and applying best practice development processes.")
          "1x6fd3cw9pq45k71rgmxi91hmdmnbf1xxvlfwv31fmzs5255dlbw"))))
     (build-system python-build-system)
     (arguments
-     `(#:python ,python-2
-       #:phases
+     `(#:phases
        (modify-phases %standard-phases
          (add-before 'install 'disable-egg-compression
            (lambda _
@@ -344,23 +343,26 @@ security, and applying best practice development processes.")
                #t))))))
     ;; TODO: Add optional inputs for testing and building documentation.
     (native-inputs
-     `(("python2-mock" ,python2-mock)
-       ("python2-setuptools" ,python2-setuptools)))
+     `(("python-mock" ,python-mock)
+       ("python-setuptools" ,python-setuptools)))
     (propagated-inputs
-     `(("python2-ndg-httpsclient" ,python2-ndg-httpsclient)
-       ("python2-werkzeug" ,python2-werkzeug)
-       ("python2-six" ,python2-six)
-       ("python2-requests" ,python2-requests)
-       ("python2-pytz" ,python2-pytz)
-       ("python2-pyrfc3339" ,python2-pyrfc3339)
-       ("python2-pyasn1" ,python2-pyasn1)
-       ("python2-cryptography" ,python2-cryptography)
-       ("python2-pyopenssl" ,python2-pyopenssl)))
+     `(("python-ndg-httpsclient" ,python-ndg-httpsclient)
+       ("python-werkzeug" ,python-werkzeug)
+       ("python-six" ,python-six)
+       ("python-requests" ,python-requests)
+       ("python-pytz" ,python-pytz)
+       ("python-pyrfc3339" ,python-pyrfc3339)
+       ("python-pyasn1" ,python-pyasn1)
+       ("python-cryptography" ,python-cryptography)
+       ("python-pyopenssl" ,python-pyopenssl)))
     (home-page "https://github.com/letsencrypt/letsencrypt")
     (synopsis "ACME protocol implementation in Python")
     (description "ACME protocol implementation in Python")
     (license license:asl2.0)))
 
+(define-public python2-acme
+  (package-with-python2 python-acme))
+
 (define-public letsencrypt
   (package
     (name "letsencrypt")
@@ -379,7 +381,7 @@ security, and applying best practice development processes.")
      `(("python2-nose" ,python2-nose)
        ("python2-mock" ,python2-mock)))
     (propagated-inputs
-     `(("acme" ,acme)
+     `(("python2-acme" ,python2-acme)
        ("python2-zope-interface" ,python2-zope-interface)
        ("python2-pythondialog" ,python2-pythondialog)
        ("python2-pyrfc3339" ,python2-pyrfc3339)