summary refs log tree commit diff
path: root/gnu/packages/tls.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2015-11-23 23:10:12 -0500
committerDavid Thompson <dthompson2@worcester.edu>2015-12-05 09:44:38 -0500
commit7890e3baf36b6ba3a8d29cd5d088736fd68f4cf4 (patch)
tree58b8913c4e8977725bd68e4a3002e8b29d626562 /gnu/packages/tls.scm
parent38b8f9b21b9629c13523b085154471836c309ae5 (diff)
downloadguix-7890e3baf36b6ba3a8d29cd5d088736fd68f4cf4.tar.gz
gnu: Add acme.
* gnu/packages/tls.scm (acme): New variable.
Diffstat (limited to 'gnu/packages/tls.scm')
-rw-r--r--gnu/packages/tls.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 1a0eeb2708..14df8dbdf4 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -3,6 +3,7 @@
 ;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
 ;;; Copyright © 2014 Ian Denhardt <ian@zenhack.net>
 ;;; Copyright © 2013, 2015 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2015 Leo Famulari <leo@famulari.name>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -26,14 +27,17 @@
   #:use-module (guix utils)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system perl)
+  #:use-module (guix build-system python)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages)
   #:use-module (gnu packages guile)
   #:use-module (gnu packages libffi)
   #:use-module (gnu packages libidn)
+  #:use-module (gnu packages ncurses)
   #:use-module (gnu packages nettle)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages pkg-config)
+  #:use-module (gnu packages python)
   #:use-module (gnu packages texinfo)
   #:use-module (gnu packages base))
 
@@ -320,6 +324,39 @@ security, and applying best practice development processes.")
                      "file://COPYING"
                      "See COPYING in the distribution.")))))
 
+(define-public acme
+  (package
+    (name "acme")
+    (version "0.1.0")
+    (source (origin
+      (method url-fetch)
+      (uri (string-append "https://pypi.python.org/packages/source/a/acme/acme-"
+                          version ".tar.gz"))
+      (sha256
+        (base32
+          "0fj0m04zzdxx23vazl00ilqyl3jxqq9c9p4x61pfz1zps7nbzsy3"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:python ,python-2))
+    ;; TODO: Add optional inputs for testing and building documentation.
+    (native-inputs
+     `(("python2-mock" ,python2-mock)
+       ("python2-setuptools" ,python2-setuptools)))
+    (propagated-inputs
+     `(("python2-ndg-httpsclient" ,python2-ndg-httpsclient)
+       ("python2-werkzeug" ,python2-werkzeug)
+       ("python2-six" ,python2-six)
+       ("python2-requests" ,python2-requests)
+       ("python2-pytz" ,python2-pytz)
+       ("python2-pyrfc3339" ,python2-pyrfc3339)
+       ("python2-pyasn1" ,python2-pyasn1)
+       ("python2-cryptography" ,python2-cryptography)
+       ("python2-pyopenssl" ,python2-pyopenssl)))
+    (home-page "https://github.com/letsencrypt/letsencrypt")
+    (synopsis "ACME protocol implementation in Python")
+    (description "ACME protocol implementation in Python")
+    (license license:asl2.0)))
+
 (define-public perl-net-ssleay
   (package
     (name "perl-net-ssleay")