summary refs log tree commit diff
path: root/gnu/packages/tls.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-10-13 23:00:15 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-10-13 23:07:56 +0200
commit8fc24f300b56bcebb7a1257f99767d5e964c52a9 (patch)
tree79f4f8858742e673753774d47c8d831872303a87 /gnu/packages/tls.scm
parent378ebc048c033744b4f1dc13e16f4f2277d7529f (diff)
downloadguix-8fc24f300b56bcebb7a1257f99767d5e964c52a9.tar.gz
gnu: OpenSSL@1.0: Incorporate grafted changes.
* gnu/packages/tls.scm (openssl-1.0): Update to 1.0.2t.
[replacement]: Remove.
[arguments]: Add #:parallel-build?.
(openssl-1.0.2t): Remove variable.
Diffstat (limited to 'gnu/packages/tls.scm')
-rw-r--r--gnu/packages/tls.scm28
1 files changed, 4 insertions, 24 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 2def6ee703..3aa3efbfb8 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -391,8 +391,7 @@ required structures.")
   (package
     (inherit openssl)
     (name "openssl")
-    (version "1.0.2s")
-    (replacement openssl-1.0.2t)
+    (version "1.0.2t")
     (source (origin
               (method url-fetch)
               (uri (list (string-append "https://www.openssl.org/source/openssl-"
@@ -404,7 +403,7 @@ required structures.")
                                         "/openssl-" version ".tar.gz")))
               (sha256
                (base32
-                "15mbmg8hf7s12vr3v2bdc0pi9y4pdbnsxhzk4fyyap42jaa5rgfa"))
+                "1g67ra0ph7gpz6fgvv1i96d792jmd6ymci5kk53vbikszr74djql"))
               (patches (search-patches "openssl-runpath.patch"
                                        "openssl-c-rehash-in.patch"))))
     (outputs '("out"
@@ -412,6 +411,8 @@ required structures.")
                "static"))               ;6MiB of .a files
     (arguments
      (substitute-keyword-arguments (package-arguments openssl)
+       ;; Parallel build is not supported in 1.0.x.
+       ((#:parallel-build? _ #f) #f)
        ((#:phases phases)
         `(modify-phases ,phases
            (add-before 'patch-source-shebangs 'patch-tests
@@ -474,27 +475,6 @@ required structures.")
                                                          ,version "/misc"))
                  #t)))))))))
 
-(define openssl-1.0.2t
-  (package
-    (inherit openssl)
-    (version "1.0.2t")
-    (source (origin
-              (inherit (package-source openssl-1.0))
-              (uri (list (string-append "https://www.openssl.org/source/openssl-"
-                                        version ".tar.gz")
-                         (string-append "ftp://ftp.openssl.org/source/"
-                                        "openssl-" version ".tar.gz")
-                         (string-append "ftp://ftp.openssl.org/source/old/"
-                                        (string-trim-right version char-set:letter)
-                                        "/openssl-" version ".tar.gz")))
-              (sha256
-               (base32
-                "1g67ra0ph7gpz6fgvv1i96d792jmd6ymci5kk53vbikszr74djql"))))
-    (arguments
-     (substitute-keyword-arguments (package-arguments openssl-1.0)
-       ;; Parallel build is not supported in 1.0.x.
-       ((#:parallel-build? _ #f) #f)))))
-
 (define-public libressl
   (package
     (name "libressl")