summary refs log tree commit diff
path: root/gnu/packages/tls.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2019-10-14 10:03:19 +0200
committerMathieu Othacehe <m.othacehe@gmail.com>2019-10-14 10:03:19 +0200
commitc206f1914e9299b3f9a8b8be295a02f14acc67b3 (patch)
tree7cd0441f380b53e64badd6ee063bbf7ccbdf27a5 /gnu/packages/tls.scm
parent4d14902b9402a83db444d8d6818d0a4f438ce8c4 (diff)
parent396b05f04ed5c5ad6141bd1b4f70f51561a97aad (diff)
downloadguix-c206f1914e9299b3f9a8b8be295a02f14acc67b3.tar.gz
Merge remote-tracking branch 'signed/master' into core-updates
Diffstat (limited to 'gnu/packages/tls.scm')
-rw-r--r--gnu/packages/tls.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index c45767c1b3..2def6ee703 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -392,6 +392,7 @@ required structures.")
     (inherit openssl)
     (name "openssl")
     (version "1.0.2s")
+    (replacement openssl-1.0.2t)
     (source (origin
               (method url-fetch)
               (uri (list (string-append "https://www.openssl.org/source/openssl-"
@@ -473,6 +474,27 @@ required structures.")
                                                          ,version "/misc"))
                  #t)))))))))
 
+(define openssl-1.0.2t
+  (package
+    (inherit openssl)
+    (version "1.0.2t")
+    (source (origin
+              (inherit (package-source openssl-1.0))
+              (uri (list (string-append "https://www.openssl.org/source/openssl-"
+                                        version ".tar.gz")
+                         (string-append "ftp://ftp.openssl.org/source/"
+                                        "openssl-" version ".tar.gz")
+                         (string-append "ftp://ftp.openssl.org/source/old/"
+                                        (string-trim-right version char-set:letter)
+                                        "/openssl-" version ".tar.gz")))
+              (sha256
+               (base32
+                "1g67ra0ph7gpz6fgvv1i96d792jmd6ymci5kk53vbikszr74djql"))))
+    (arguments
+     (substitute-keyword-arguments (package-arguments openssl-1.0)
+       ;; Parallel build is not supported in 1.0.x.
+       ((#:parallel-build? _ #f) #f)))))
+
 (define-public libressl
   (package
     (name "libressl")