summary refs log tree commit diff
path: root/gnu/packages/tls.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-05-02 15:43:50 +0200
committerLudovic Courtès <ludo@gnu.org>2016-05-02 17:58:17 +0200
commita909b5765883cfecd6913ac24b44b1e3e22eab76 (patch)
treeae62ca583f88f4d11555574163237fae8123ec95 /gnu/packages/tls.scm
parent8c78aeb72436ff4b152cfd29f593753e2e759b75 (diff)
downloadguix-a909b5765883cfecd6913ac24b44b1e3e22eab76.tar.gz
gnu: openssl: Add "doc" output.
* gnu/packages/tls.scm (openssl)[outputs]: Add "doc".
[arguments]: Add 'move-man3-pages' phase.
Diffstat (limited to 'gnu/packages/tls.scm')
-rw-r--r--gnu/packages/tls.scm15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 08c869bc30..f1e7a21c1c 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -212,6 +212,7 @@ required structures.")
                                       "openssl-c-rehash-in.patch"))))
    (build-system gnu-build-system)
    (outputs '("out"
+              "doc"                               ;1.5MiB of man3 pages
               "static"))                          ;6MiB of .a files
    (native-inputs `(("perl" ,perl)))
    (arguments
@@ -282,6 +283,20 @@ required structures.")
                           (delete-file file))
                         (find-files lib "\\.a$"))
               #t)))
+        (add-after 'install 'move-man3-pages
+          (lambda* (#:key outputs #:allow-other-keys)
+            ;; Move section 3 man pages to "doc".
+            (let* ((out    (assoc-ref outputs "out"))
+                   (man3   (string-append out "/share/man/man3"))
+                   (doc    (assoc-ref outputs "doc"))
+                   (target (string-append doc "/share/man/man3")))
+              (mkdir-p target)
+              (for-each (lambda (file)
+                          (rename-file file
+                                       (string-append target "/"
+                                                      (basename file))))
+                        (find-files man3))
+              #t)))
         (add-before
          'patch-source-shebangs 'patch-tests
          (lambda* (#:key inputs native-inputs #:allow-other-keys)