summary refs log tree commit diff
path: root/gnu/packages/tls.scm
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@inbox.ru>2017-05-28 09:39:05 +0100
committerLudovic Courtès <ludo@gnu.org>2017-05-30 10:09:03 +0200
commit8a9b08b503c209c020f7e7dab16b8818208003f6 (patch)
treeee8c0d3d1d0bc8e75ff70de7134fb16400ce51f3 /gnu/packages/tls.scm
parentff647c3d382dff13f6f43f817520053178671549 (diff)
downloadguix-8a9b08b503c209c020f7e7dab16b8818208003f6.tar.gz
gnu: openssl: Delete ELF files from tarball.
Otherwise building openssl fails: substitute can't decode binary ELF file:

  ice-9/boot-9.scm:760:25: In procedure dispatch-exception:
  ice-9/boot-9.scm:760:25: Throw to key `decoding-error' with args
  `("peek-char" "input decoding error" 84 #<input: test/ssltest_old 15>)'.

* gnu/packages/tls.scm (openssl)[source]: Add 'snippet'.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/tls.scm')
-rw-r--r--gnu/packages/tls.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 6a0b0637a2..349e951188 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -235,6 +235,13 @@ required structures.")
              (sha256
               (base32
                "037kvpisc6qh5dkppcwbm5bg2q800xh2hma3vghz8xcycmdij1yf"))
+             (snippet
+              '(begin
+                 ;; Remove ELF files.  'substitute*' can't read them.
+                 (delete-file "test/ssltest_old")
+                 (delete-file "test/v3ext")
+                 (delete-file "test/x509aux")
+                 #t))
              (patches (search-patches "openssl-runpath.patch"
                                       "openssl-c-rehash-in.patch"))))
    (build-system gnu-build-system)