summary refs log tree commit diff
path: root/gnu/packages/tls.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-11-10 12:07:23 -0500
committerLeo Famulari <leo@famulari.name>2017-11-11 11:52:24 -0500
commit76b21274ad4755ffa5e4271be7a4a85993d6002d (patch)
tree474fb4f2252f8c15a8b866e9e85ceb0c36937db7 /gnu/packages/tls.scm
parent738d0cd665ef89a77af0b1568aea68d29bc749d6 (diff)
downloadguix-76b21274ad4755ffa5e4271be7a4a85993d6002d.tar.gz
gnu: gnutls: Don't allow a reference to net-tools.
* gnu/packages/tls.scm (gnutls)[arguments]: Add net-tools
to #:disallowed-references.
Diffstat (limited to 'gnu/packages/tls.scm')
-rw-r--r--gnu/packages/tls.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index e87149a595..314a67af7c 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -153,7 +153,9 @@ living in the same process.")
                "15ihq6p0hnnhs8cnjrkj40dmlcaa1jjg8xg0g2ydbnlqs454ixbr"))))
     (build-system gnu-build-system)
     (arguments
-     '(#:configure-flags
+     `(; Ensure we don't keep a reference to this buggy software.
+       #:disallowed-references (,net-tools)
+       #:configure-flags
        (list
              ;; GnuTLS doesn't consult any environment variables to specify
              ;; the location of the system-wide trust store.  Instead it has a