summary refs log tree commit diff
path: root/gnu/packages/tls.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-19 08:50:35 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-19 08:50:35 +0100
commitdd0568a77951804d97884a0a0a3a3ed38ca0a184 (patch)
tree75b5bfcb64e0e3477a725a93ed85eda327c52d44 /gnu/packages/tls.scm
parent142cd4dc98ed439f32d2a903ff866ae345234c0f (diff)
parentbaab9eef27994575e3ce1ba7efb822725600f748 (diff)
downloadguix-dd0568a77951804d97884a0a0a3a3ed38ca0a184.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/tls.scm')
-rw-r--r--gnu/packages/tls.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index ce8abfb9a2..45ee67fa9c 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -281,6 +281,7 @@ required structures.")
   (package
    (name "openssl")
    (version "1.1.1d")
+   (replacement openssl-1.1.1e)
    (source (origin
              (method url-fetch)
              (uri (list (string-append "https://www.openssl.org/source/openssl-"
@@ -402,6 +403,24 @@ required structures.")
    (license license:openssl)
    (home-page "https://www.openssl.org/")))
 
+(define openssl-1.1.1e
+  (package
+   (inherit openssl)
+   (version "1.1.1e")
+   (source (origin
+             (method url-fetch)
+             (uri (list (string-append "https://www.openssl.org/source/openssl-"
+                                       version ".tar.gz")
+                        (string-append "ftp://ftp.openssl.org/source/"
+                                       "openssl-" version ".tar.gz")
+                        (string-append "ftp://ftp.openssl.org/source/old/"
+                                       (string-trim-right version char-set:letter)
+                                       "/openssl-" version ".tar.gz")))
+             (patches (search-patches "openssl-1.1-c-rehash-in.patch"))
+             (sha256
+              (base32
+               "1gnwlri1dphr5wdzmg9vlhkh6aq2yqgpfkpmffzwjlfb26n62kv9"))))))
+
 (define-public openssl-1.0
   (package
     (inherit openssl)