summary refs log tree commit diff
path: root/gnu/packages/tls.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-09-26 12:51:39 -0400
committerLeo Famulari <leo@famulari.name>2016-09-26 17:09:05 -0400
commit8be42e5dafd09c1ccc9400ac87b3812dae829f32 (patch)
treeae531f6cabd703f111a0593c321fcebc86d84dad /gnu/packages/tls.scm
parent58478cc1cb225e2eed979afa4021f850f3ebf121 (diff)
downloadguix-8be42e5dafd09c1ccc9400ac87b3812dae829f32.tar.gz
gnu: openssl: Update replacement to 1.0.2j [fixes CVE-2016-7052].
* gnu/packages/tls.scm (openssl): Update replacement to 1.0.2j.
(openssl-1.0.2i): Replace with...
(openssl-1.0.2j): ... new variable.
Diffstat (limited to 'gnu/packages/tls.scm')
-rw-r--r--gnu/packages/tls.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 15e3e43167..93c78aee5d 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -229,7 +229,7 @@ required structures.")
 (define-public openssl
   (package
    (name "openssl")
-   (replacement openssl-1.0.2i)
+   (replacement openssl-1.0.2j)
    (version "1.0.2h")
    (source (origin
              (method url-fetch)
@@ -368,11 +368,11 @@ required structures.")
    (license license:openssl)
    (home-page "http://www.openssl.org/")))
 
-(define openssl-1.0.2i
+(define openssl-1.0.2j
   (package (inherit openssl)
     (source
       (let ((name "openssl")
-            (version "1.0.2i"))
+            (version "1.0.2j"))
         (origin
           (method url-fetch)
           (uri (list (string-append "ftp://ftp.openssl.org/source/"
@@ -382,7 +382,7 @@ required structures.")
                                     "/" name "-" version ".tar.gz")))
           (sha256
            (base32
-            "0vyy038676cv3m2523fi9ll9nkjxadqdnz18zdp5nm6925yli1wj"))
+            "0cf4ar97ijfc7mg35zdgpad6x8ivkdx9qii6mz35khi1ps9g5bz7"))
           (patches (search-patches "openssl-runpath.patch"
                                    "openssl-c-rehash-in.patch")))))))