summary refs log tree commit diff
path: root/gnu/packages/tls.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-01-05 18:10:38 +0200
committerEfraim Flashner <efraim@flashner.co.il>2016-01-05 21:06:59 +0200
commit5a75865f9d6ae08251d789251aa1ea4eac23ab0f (patch)
treee53e831411e9e6c8fd1e97715e2a8ff176d1b361 /gnu/packages/tls.scm
parent3ea110b704fb6ffcb512b9ff708948c06d594598 (diff)
downloadguix-5a75865f9d6ae08251d789251aa1ea4eac23ab0f.tar.gz
gnu: gnutls: Update to 3.4.7.
* gnu/packages/tls.scm (gnutls): Update to 3.4.7.
[source]: Remove gnutls-doc-fix.patch.
[arguments]: Remove delete-prebuilt-unfixed-info-file phase.
[native-inputs]: Remove texinfo.
* gnu-system.am (dist_patch_DATA): Remove gnutls-doc-fix.patch
Diffstat (limited to 'gnu/packages/tls.scm')
-rw-r--r--gnu/packages/tls.scm13
1 files changed, 2 insertions, 11 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 494128eeae..c10d1cbfc7 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -107,7 +107,7 @@ living in the same process.")
 (define-public gnutls
   (package
     (name "gnutls")
-    (version "3.4.5")
+    (version "3.4.7")
     (source (origin
              (method url-fetch)
              (uri
@@ -118,8 +118,7 @@ living in the same process.")
                              "/gnutls-" version ".tar.xz"))
              (sha256
               (base32
-               "1bks1zpmhmnkz2v32dd9b44pz6x0a5w4yi9zzwsd0a078vhbi25g"))
-             (patches (list (search-patch "gnutls-doc-fix.patch")))))
+               "0nifi3mr5jhz608pidkp8cjs4vwfj1m2qczsjrgpnp99615rxgn1"))))
     (build-system gnu-build-system)
     (arguments
      '(#:configure-flags
@@ -143,13 +142,6 @@ living in the same process.")
 
        #:phases (modify-phases %standard-phases
                   (add-after
-                   'unpack 'delete-prebuilt-unfixed-info-file
-                   (lambda _
-                     ;; XXX Delete the prebuilt info file, so that it will be
-                     ;; rebuilt with the fixes in gnutls-doc-fix.patch.
-                     (delete-file "doc/gnutls.info")
-                     #t))
-                  (add-after
                    'install 'move-doc
                    (lambda* (#:key outputs #:allow-other-keys)
                      ;; Copy the 4.1 MiB of section 3 man pages to "doc".
@@ -166,7 +158,6 @@ living in the same process.")
                "doc"))                            ;4.1 MiB of man pages
     (native-inputs
      `(("pkg-config" ,pkg-config)
-       ("texinfo" ,texinfo) ; XXX needed only to replace prebuilt, unfixed docs.
        ("which" ,which)))
     (inputs
      `(("guile" ,guile-2.0)