summary refs log tree commit diff
path: root/gnu/packages/tls.scm
diff options
context:
space:
mode:
authorMatthew James Kraai <kraai@ftbfs.org>2021-07-03 17:16:57 -0700
committerEfraim Flashner <efraim@flashner.co.il>2021-07-05 10:05:07 +0300
commit0ec7559875eacb85fec289377ff7b37723dd251e (patch)
treeeef2251c00b4ed50dc784a09defd240e9f31ad46 /gnu/packages/tls.scm
parente5a84776127f36d66df3f298cf6b76c9f449dc45 (diff)
downloadguix-0ec7559875eacb85fec289377ff7b37723dd251e.tar.gz
gnu: mbedtls-apache: Update to 2.26.0.
* gnu/packages/tls.scm (mbedtls-apache): Update to 2.26.0.
[source]: Add snippet.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/tls.scm')
-rw-r--r--gnu/packages/tls.scm15
1 files changed, 12 insertions, 3 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 60005cf339..c1e8b46a84 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -946,7 +946,7 @@ then ported to the GNU / Linux environment.")
     (name "mbedtls-apache")
     ;; XXX Check whether ‘-Wformat-signedness’ still breaks mbedtls-for-hiawatha
     ;; when updating.
-    (version "2.23.0")
+    (version "2.26.0")
     (source
      (origin
        (method git-fetch)
@@ -954,8 +954,17 @@ then ported to the GNU / Linux environment.")
              (url "https://github.com/ARMmbed/mbedtls")
              (commit (string-append "mbedtls-" version))))
        (sha256
-        (base32 "13fa9h2i989cbf8n8c0j019mshv6wg213va18my1s787lhcq2d62"))
-       (file-name (git-file-name name version))))
+        (base32 "0scwpmrgvg6q7rvqkc352d2fqlsx0aylcbyibcp1f1rsn8iiif2m"))
+       (file-name (git-file-name name version))
+       (modules '((guix build utils)))
+       (snippet
+        '(begin
+           ;; Can be removed with the next version.
+           ;; Reduce level of format truncation warnings due to false positives.
+           ;; https://github.com/ARMmbed/mbedtls/commit/2065a8d8af27c6cb1e40c9462b5933336dca7434
+           (substitute* "CMakeLists.txt"
+             (("Wformat-truncation=2") "Wformat-truncation"))
+           #t))))
     (build-system cmake-build-system)
     (arguments
      `(#:configure-flags