summary refs log tree commit diff
path: root/gnu/packages/tls.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-09-09 18:17:38 +0200
committerLudovic Courtès <ludo@gnu.org>2015-09-09 18:17:38 +0200
commit4fb254a3399a62b061fdde365fc8d53d6a6fc23e (patch)
tree2b972f9eb534ef640e38efb90aa15dd085ca544e /gnu/packages/tls.scm
parentb6cb13583b9aa9e6e7470ac8e873e00a8c5a2500 (diff)
downloadguix-4fb254a3399a62b061fdde365fc8d53d6a6fc23e.tar.gz
gnu: openssl: Install data and documentation to PREFIX/share.
* gnu/packages/tls.scm (openssl)[arguments]: Add 'fix-man-dir' phase.
  Pass --openssldir=PREFIX/share/openssl-VERSION to ./config.
Diffstat (limited to 'gnu/packages/tls.scm')
-rw-r--r--gnu/packages/tls.scm16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 5bbe367286..0bce6e1bc7 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -204,6 +204,15 @@ required structures.")
       #:test-target "test"
       #:phases
       (modify-phases %standard-phases
+        (add-before
+         'configure 'fix-man-dir
+         (lambda* (#:key outputs #:allow-other-keys)
+           ;; The default MANDIR is some unusual place.  Fix that.
+           (let ((out (assoc-ref outputs "out")))
+             (substitute* "Makefile.org"
+               (("^MANDIR[[:blank:]]*=.*$")
+                (string-append "MANDIR = " out "/share/man\n")))
+             #t)))
         (replace
          'configure
          (lambda* (#:key outputs #:allow-other-keys)
@@ -212,6 +221,13 @@ required structures.")
               (system* "./config"
                        "shared"                   ;build shared libraries
                        "--libdir=lib"
+
+                       ;; The default for this catch-all directory is
+                       ;; PREFIX/ssl.  Change that to something more
+                       ;; conventional.
+                       (string-append "--openssldir=" out
+                                      "/share/openssl-" ,version)
+
                        (string-append "--prefix=" out)
 
                        ;; XXX FIXME: Work around a code generation bug in GCC