summary refs log tree commit diff
path: root/gnu/packages/tor.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-11-19 09:32:01 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-11-19 10:11:25 +0100
commit7eb9b6ed6cf72c681a0d1816cc9fa63a38259319 (patch)
treeffa2b53c58cd61667680a717c6b4a9af19ac967e /gnu/packages/tor.scm
parentcab90f08321fcb3e21547de3661f67bea57caade (diff)
downloadguix-7eb9b6ed6cf72c681a0d1816cc9fa63a38259319.tar.gz
gnu: onionshare: Run tests conditionally.
* gnu/packages/tor.scm (onionshare)[arguments]: Respect TESTS?.
Diffstat (limited to 'gnu/packages/tor.scm')
-rw-r--r--gnu/packages/tor.scm25
1 files changed, 13 insertions, 12 deletions
diff --git a/gnu/packages/tor.scm b/gnu/packages/tor.scm
index 3fb84cd4fc..8608d00e78 100644
--- a/gnu/packages/tor.scm
+++ b/gnu/packages/tor.scm
@@ -339,18 +339,19 @@ OnionShare.")
                              (display line out)
                              (loop))))))))))
          (replace 'check
-           (lambda* (#:key inputs outputs #:allow-other-keys)
-             ;; Some tests need a writable homedir:
-             (setenv "HOME" "/tmp")
-             ;; Ensure installed modules can be found:
-             (add-installed-pythonpath inputs outputs)
-             ;; Avoid `getprotobyname` issues:
-             (setenv "EVENTLET_NO_GREENDNS" "yes")
-             ;; Make Qt render "offscreen":
-             (setenv "QT_QPA_PLATFORM" "offscreen")
-             ;; Must be run from "desktop" dir:
-             (chdir "..")
-             (invoke "./tests/run.sh")))
+           (lambda* (#:key tests? inputs outputs #:allow-other-keys)
+             (when tests?
+               ;; Some tests need a writable homedir:
+               (setenv "HOME" "/tmp")
+               ;; Ensure installed modules can be found:
+               (add-installed-pythonpath inputs outputs)
+               ;; Avoid `getprotobyname` issues:
+               (setenv "EVENTLET_NO_GREENDNS" "yes")
+               ;; Make Qt render "offscreen":
+               (setenv "QT_QPA_PLATFORM" "offscreen")
+               ;; Must be run from "desktop" dir:
+               (with-directory-excursion ".."
+                 (invoke "./tests/run.sh")))))
          (add-after 'install 'install-data
            (lambda* (#:key outputs #:allow-other-keys)
              (let* ((out (assoc-ref outputs "out"))