summary refs log tree commit diff
path: root/gnu/packages/tor.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-09-18 23:27:36 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-09-18 23:27:36 +0300
commitc4605e4c97b8763e8e043e45ce1dd4190a2d1166 (patch)
treebea38e7f4601efcac938cfa65e83199241d33b94 /gnu/packages/tor.scm
parentb8ea5204ab1d9eb9464753fa6b1af9f5705a1084 (diff)
downloadguix-c4605e4c97b8763e8e043e45ce1dd4190a2d1166.tar.gz
gnu: onionshare: Fix build.
This commit is a follow-up to b8ea5204ab.

* gnu/packages/tor.scm: Add 'gpl3+' to guix-licenses import, Add
python-build-system.
(onionshare)[licenses]: Remove license namespace.
Diffstat (limited to 'gnu/packages/tor.scm')
-rw-r--r--gnu/packages/tor.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/tor.scm b/gnu/packages/tor.scm
index fe74c3c972..0dc72a3cb9 100644
--- a/gnu/packages/tor.scm
+++ b/gnu/packages/tor.scm
@@ -20,11 +20,12 @@
 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
 
 (define-module (gnu packages tor)
-  #:use-module ((guix licenses) #:select (bsd-3 gpl2+ gpl2))
+  #:use-module ((guix licenses) #:select (bsd-3 gpl3+ gpl2+ gpl2))
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix git-download)
   #:use-module (guix build-system gnu)
+  #:use-module (guix build-system python)
   #:use-module (gnu packages)
   #:use-module (gnu packages libevent)
   #:use-module (gnu packages compression)
@@ -243,5 +244,5 @@ using a third party filesharing service.  You host the file on your own computer
 and use a Tor hidden service to make it temporarily accessible over the
 internet.  The other user just needs to use Tor Browser to download the file
 from you.")
-    (license (list license:gpl3+
-                   license:bsd-3)))) ; onionshare/socks.py
+    (license (list gpl3+
+                   bsd-3)))) ; onionshare/socks.py