summary refs log tree commit diff
path: root/gnu/packages/tor.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@posteo.net>2021-07-21 23:06:08 -0500
committerEric Bavier <bavier@posteo.net>2021-07-21 23:08:14 -0500
commit55db762b31531609f43b32680298762487702280 (patch)
tree6dbb1bd84dbe543b89a0e5e2e3c51d6d8d3b63a7 /gnu/packages/tor.scm
parente9d47ee718a5bf0cd576240b849dbc115d5147f9 (diff)
downloadguix-55db762b31531609f43b32680298762487702280.tar.gz
gnu: onionshare: Update to 2.3.2.
* gnu/packages/tor.scm (onionshare-cli, onionshare): Update to 2.3.2.
(onionshare)[inputs]: Add python-colorama.
[arguments]: Insert "import pytest" for later "pytest.mark.skip".
Diffstat (limited to 'gnu/packages/tor.scm')
-rw-r--r--gnu/packages/tor.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/tor.scm b/gnu/packages/tor.scm
index e4f16f6caa..5ad15d085d 100644
--- a/gnu/packages/tor.scm
+++ b/gnu/packages/tor.scm
@@ -45,6 +45,7 @@
   #:use-module (gnu packages glib)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages python)
+  #:use-module (gnu packages python-check)
   #:use-module (gnu packages python-crypto)
   #:use-module (gnu packages python-web)
   #:use-module (gnu packages python-xyz)
@@ -226,7 +227,7 @@ networks.")
 (define-public onionshare-cli
   (package
     (name "onionshare-cli")
-    (version "2.3.1")
+    (version "2.3.2")
     (source
       (origin
         (method git-fetch)
@@ -235,13 +236,14 @@ networks.")
               (commit (string-append "v" version))))
         (file-name (git-file-name name version))
         (sha256
-         (base32 "1llvnvb676s2cs6a4y7isxdj75ddfvskw1p93v5m35vsw7f72kqz"))))
+         (base32 "1qk0zvbaws9md1lmi0al1jc8v86l65nf7n3w1s36iwsfzazc6clv"))))
     (build-system python-build-system)
     (native-inputs
      `(("python-pytest" ,python-pytest)))
     (inputs
      ;; TODO: obfs4proxy
      `(("python-click" ,python-click)
+       ("python-colorama" ,python-colorama)
        ("python-eventlet" ,python-eventlet)
        ("python-flask" ,python-flask)
        ("python-flask-httpauth" ,python-flask-httpauth)
@@ -303,10 +305,14 @@ OnionShare.")
              ;; - test_autostart_timer_too_short
              ;; - test_autostop_timer_too_short
              (substitute* "desktop/tests/test_gui_share.py"
+               (("import os" &)
+                (string-append "import pytest\n" &))
                (("( *)def test_autost(art|op)_(timer(_too_short)?|and_[^(]*)\\(" & >)
                 (string-append > "@pytest.mark.skip\n" &)))
              ;; - test_13_quit_with_server_started_should_warn
              (substitute* "desktop/tests/test_gui_tabs.py"
+               (("import os" &)
+                (string-append "import pytest\n" &))
                (("( *)def test_13" & >)
                 (string-append > "@pytest.mark.skip\n" &)))
              ;; Remove multiline load-path adjustment, so that onionshare-cli