summary refs log tree commit diff
path: root/gnu/packages/tor.scm
diff options
context:
space:
mode:
authorAndré Batista <nandre@riseup.net>2023-11-11 19:20:41 -0300
committerLudovic Courtès <ludo@gnu.org>2023-11-15 18:29:38 +0100
commitcb9ecbef8bc126b97843d4e94595e6320a696096 (patch)
tree1a9b3162895c610e7f1931891e00ba794f11d1de /gnu/packages/tor.scm
parent9524d8cd0bc752b8b8387b0e669f780e0bd20ed1 (diff)
downloadguix-cb9ecbef8bc126b97843d4e94595e6320a696096.tar.gz
gnu: tor: Update to 0.4.8.9 [security fixes].
* gnu/packages/tor.scm (tor): Update to 0.4.8.9.

This release fixes two high severity security vulnerabilities.
The first one affects client connections to Guard relays and the
other one affects Onion Services (TROVE-2023-006).

See https://gitlab.torproject.org/tpo/core/tor/-/issues/40876 and
https://gitlab.torproject.org/tpo/core/tor/-/issues/40883

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/tor.scm')
-rw-r--r--gnu/packages/tor.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/tor.scm b/gnu/packages/tor.scm
index 71f32b3f43..d4bf27a790 100644
--- a/gnu/packages/tor.scm
+++ b/gnu/packages/tor.scm
@@ -63,14 +63,14 @@
 (define-public tor
   (package
     (name "tor")
-    (version "0.4.8.8")
+    (version "0.4.8.9")
     (source (origin
              (method url-fetch)
              (uri (string-append "https://dist.torproject.org/tor-"
                                  version ".tar.gz"))
              (sha256
               (base32
-               "0140d0zcjxi4vijvr2gk3kmnd4xa80sjj9kdcc2gzazyr84fkfr1"))))
+               "0rfgn88izn74nh6gy42ggwmiicnylp73skrlwm61n4znj247vfsr"))))
     (build-system gnu-build-system)
     (arguments
      (list #:configure-flags