summary refs log tree commit diff
path: root/gnu/packages/toys.scm
diff options
context:
space:
mode:
authorTimotej Lazar <timotej.lazar@araneo.si>2019-12-15 17:44:24 +0100
committerLudovic Courtès <ludo@gnu.org>2019-12-20 22:45:57 +0100
commit70f2920c378a8da6d50647cc3f32bedb0827096d (patch)
treec6f1957a163204c5685c9e672a75830232d6dce8 /gnu/packages/toys.scm
parent2d6f68aa3b0404c3c37568a8a7bfee692cb80337 (diff)
downloadguix-70f2920c378a8da6d50647cc3f32bedb0827096d.tar.gz
gnu: Add xsnow.
* gnu/packages/toys.scm (xsnow): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/toys.scm')
-rw-r--r--gnu/packages/toys.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/toys.scm b/gnu/packages/toys.scm
index 8c1a03b5d2..fd86aec6ef 100644
--- a/gnu/packages/toys.scm
+++ b/gnu/packages/toys.scm
@@ -1,6 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2019 Jesse Gibbons <jgibbons2357+guix@gmail.com>
+;;; Copyright © 2019 Timotej Lazar <timotej.lazar@araneo.si>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -20,9 +21,14 @@
 (define-module (gnu packages toys)
   #:use-module (gnu packages bison)
   #:use-module (gnu packages flex)
+  #:use-module (gnu packages gtk)
   #:use-module (gnu packages ncurses)
   #:use-module (gnu packages perl)
+  #:use-module (gnu packages pkg-config)
+  #:use-module (gnu packages xml)
+  #:use-module (gnu packages xorg)
   #:use-module (guix build-system gnu)
+  #:use-module (guix download)
   #:use-module (guix git-download)
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix packages))
@@ -156,3 +162,41 @@ The GNU project hosts a similar collection of filters, the GNU talkfilters.")
              license:public-domain      ; jethro, kraut, ken, studly
              license:gpl1+         ; cockney, jive, nyc only say "gpl"
              license:expat)))))    ; newspeak
+
+(define-public xsnow
+  (package
+    (name "xsnow")
+    (version "2.0.15")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://www.ratrabbit.nl/ratrabbit/system/files/xsnow/xsnow-"
+             version ".tar.gz"))
+       (sha256
+        (base32 "086s42frbz9bk550414v908yrax4iwwlvlxv4zwp39cyp7wgws03"))))
+    (build-system gnu-build-system)
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (add-before 'configure 'fix-install-path
+           (lambda _
+             ;; Install program to bin instead of games.
+             (substitute* "src/Makefile.in"
+               (("(gamesdir = \\$\\(exec_prefix\\)/)games" _ prefix)
+                (string-append prefix "bin")))
+             #t)))))
+    (inputs
+     `(("gtk+" ,gtk+)
+       ("libx11" ,libx11)
+       ("libxpm" ,libxpm)
+       ("libxt" ,libxt)
+       ("libxxml2" ,libxml2)))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (home-page "https://www.ratrabbit.nl/ratrabbit/content/xsnow/introduction")
+    (synopsis "Let it snow on the desktop")
+    (description "@code{Xsnow} animates snowfall and Santa with reindeer on
+the desktop background.  Additional customizable effects include wind, stars
+and various scenery elements.")
+    (license license:gpl3+)))