summary refs log tree commit diff
path: root/gnu/packages/tryton.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:39 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:32 +0200
commitac3a70de7ddb5b17f23f2f0d3eef45fea9a2255e (patch)
treea5134a7eec1fb0ba42c9d7ad55bd241f33fa3d6a /gnu/packages/tryton.scm
parent99b4d93a1965c84b548b97feaec910721a59e64b (diff)
downloadguix-ac3a70de7ddb5b17f23f2f0d3eef45fea9a2255e.tar.gz
gnu: Add trytond-sale-gift-card.
* gnu/packages/tryton.scm (trytond-sale-gift-card): New variable.
Diffstat (limited to 'gnu/packages/tryton.scm')
-rw-r--r--gnu/packages/tryton.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 7391d7e57a..980addcf3e 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -3158,6 +3158,33 @@ line.")
 on sale based on criteria.")
     (license license:gpl3+)))
 
+(define-public trytond-sale-gift-card
+  (package
+    (name "trytond-sale-gift-card")
+    (version "6.0.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_sale_gift_card" version))
+       (sha256
+        (base32 "0bbcgm7xs5hmn3axz62jkarhl9v43nk9mk9zldlf9qrfqy89fd80"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "sale_gift_card"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-account" ,trytond-account)
+       ("trytond-account-invoice" ,trytond-account-invoice)
+       ("trytond-company" ,trytond-company)
+       ("trytond-product" ,trytond-product)
+       ("trytond-sale" ,trytond-sale)
+       ("trytond-stock" ,trytond-stock)))
+    (home-page "https://docs.tryton.org/projects/modules-sale-gift-card")
+    (synopsis "Tryton module to manage gift cards")
+    (description "The @emph{Sale Gift Card} Tryton module manages the selling
+and redeeming of gift cards.")
+    (license license:gpl3+)))
+
 (define-public trytond-stock
   (package
     (name "trytond-stock")