summary refs log tree commit diff
path: root/gnu/packages/tryton.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:54 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:34 +0200
commit079b7268bf0fdffe9ba6c31e6b05e8b62cff06e6 (patch)
treeb7b6e851da8fde1675edd9711d669834831d3380 /gnu/packages/tryton.scm
parent67b37a20521c91d4f22226404cb5b53507eaf282 (diff)
downloadguix-079b7268bf0fdffe9ba6c31e6b05e8b62cff06e6.tar.gz
gnu: Add trytond-stock-secondary-unit.
* gnu/packages/tryton.scm (trytond-stock-secondary-unit): New variable.
Diffstat (limited to 'gnu/packages/tryton.scm')
-rw-r--r--gnu/packages/tryton.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index c27a577a8d..3042c08dfa 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -4103,6 +4103,29 @@ reducing stock level by proposing to consume earlier.")
 stock quantity issues.")
     (license license:gpl3+)))
 
+(define-public trytond-stock-secondary-unit
+  (package
+    (name "trytond-stock-secondary-unit")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_stock_secondary_unit" version))
+       (sha256
+        (base32 "0s4nryiirdbndm2sz5aqpk2mzw9zxah92gmh6433sj5zyc6a22if"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "stock_secondary_unit"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-product" ,trytond-product)
+       ("trytond-stock" ,trytond-stock)))
+    (home-page "https://docs.tryton.org/projects/modules-stock-secondary-unit")
+    (synopsis "Tryton module to add a secondary unit on stock move")
+    (description "The @emph{Stock Secondary Unit} Tryton module adds a
+secondary unit of measure on the stock move.")
+    (license license:gpl3+)))
+
 (define-public trytond-stock-supply
   (package
     (name "trytond-stock-supply")