summary refs log tree commit diff
path: root/gnu/packages/tryton.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:21 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:29 +0200
commit8688cc9442377ad743bc50d77943f0cd19d3c076 (patch)
treec432ce6b33d349aeef403131efa8f26146c2fceb /gnu/packages/tryton.scm
parentc0a3a5218ce1ff5fcfcb014af88b52736b2b8af8 (diff)
downloadguix-8688cc9442377ad743bc50d77943f0cd19d3c076.tar.gz
gnu: Add trytond-marketing-automation.
* gnu/packages/tryton.scm (trytond-marketing-automation): New variable.
Diffstat (limited to 'gnu/packages/tryton.scm')
-rw-r--r--gnu/packages/tryton.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index ed9b0745ba..a8c562f808 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -1922,6 +1922,33 @@ authenticate users via a LDAP server.")
 fundamentals for marketing modules.")
     (license license:gpl3+)))
 
+(define-public trytond-marketing-automation
+  (package
+    (name "trytond-marketing-automation")
+    (version "6.0.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_marketing_automation" version))
+       (sha256
+        (base32 "0c2bjkxkpkjqm5zqk0r0gcxm1cxgixm6xxhh16j46vy7d4zssgsp"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "marketing_automation"))
+    (native-inputs
+     `(,@%standard-trytond-native-inputs
+       ("trytond-party" ,trytond-party)))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-marketing" ,trytond-marketing)
+       ("trytond-web-shortener" ,trytond-web-shortener)))
+    (home-page "https://docs.tryton.org/projects/modules-marketing-automation")
+    (synopsis "Tryton module to plan, coordinate and manage marketing
+campaigns")
+    (description "The @emph{Marketing Automation} Tryton module allows
+marketing actions to be automated.  It is based on scenarios and activities
+that are executed on selected records.")
+    (license license:gpl3+)))
+
 (define-public trytond-party
   (package
     (name "trytond-party")