summary refs log tree commit diff
path: root/gnu/packages/tryton.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:54 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:34 +0200
commitda2be8d5380acd16b92bfb52c622282d66439e97 (patch)
tree37a9a95d1cde62f2ce73cc52a994ee616e72c6d7 /gnu/packages/tryton.scm
parent079b7268bf0fdffe9ba6c31e6b05e8b62cff06e6 (diff)
downloadguix-da2be8d5380acd16b92bfb52c622282d66439e97.tar.gz
gnu: Add trytond-stock-shipment-cost.
* gnu/packages/tryton.scm (trytond-stock-shipment-cost): New variable.
Diffstat (limited to 'gnu/packages/tryton.scm')
-rw-r--r--gnu/packages/tryton.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 3042c08dfa..ad39f89227 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -4126,6 +4126,30 @@ stock quantity issues.")
 secondary unit of measure on the stock move.")
     (license license:gpl3+)))
 
+(define-public trytond-stock-shipment-cost
+  (package
+    (name "trytond-stock-shipment-cost")
+    (version "6.0.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_stock_shipment_cost" version))
+       (sha256
+        (base32 "13c940pz5ivqj9qk6b5nbid2xfkjnnijjmbz1bn7ic7ydfpiqy8j"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "stock_shipment_cost"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-product" ,trytond-product)
+       ("trytond-stock" ,trytond-stock)))
+    (home-page "https://docs.tryton.org/projects/modules-stock-shipment-cost")
+    (synopsis "Tryton module for stock shipment cost")
+    (description "The @emph{Stock Shipment Cost} Tryton Module adds a shipment
+cost on the outgoing moves which is calculated from the carrier purchase
+price.  This cost is added to the product margin reports.")
+    (license license:gpl3+)))
+
 (define-public trytond-stock-supply
   (package
     (name "trytond-stock-supply")