summary refs log tree commit diff
path: root/gnu/packages/tryton.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:56 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:35 +0200
commit2788e17484543fe1cc172eb4ac9627941be68e93 (patch)
treeaf468e570f62cda64ed48230bcf40e781713fd7c /gnu/packages/tryton.scm
parentd8a014aac9677cd3d6f3b5b11c706c1ee6f1dd85 (diff)
downloadguix-2788e17484543fe1cc172eb4ac9627941be68e93.tar.gz
gnu: Add trytond-stock-supply-production.
* gnu/packages/tryton.scm (trytond-stock-supply-production): New variable.
Diffstat (limited to 'gnu/packages/tryton.scm')
-rw-r--r--gnu/packages/tryton.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index d1d093f2e4..9f29d62072 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -4280,3 +4280,29 @@ a supplying may happens at any day of the week.")
     (description "The @emph{Stock Supply Forecast} Tryton module takes
 forecast into account to compute purchase requests.")
     (license license:gpl3+)))
+
+(define-public trytond-stock-supply-production
+  (package
+    (name "trytond-stock-supply-production")
+    (version "6.0.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_stock_supply_production" version))
+       (sha256
+        (base32 "1qyvj61hwn3xgjqagnr7d28qkiniw5fp0b5vmn9wii9grf7p4m8d"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "stock_supply_production"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-product" ,trytond-product)
+       ("trytond-production" ,trytond-production)
+       ("trytond-stock" ,trytond-stock)
+       ("trytond-stock-supply" ,trytond-stock-supply)))
+    (home-page
+     "https://docs.tryton.org/projects/modules-stock-supply-production")
+    (synopsis "Tryton module for stock supply of production")
+    (description "The @emph{Stock Supply Production} module adds automatic
+supply mechanisms via production request.")
+    (license license:gpl3+)))