summary refs log tree commit diff
path: root/gnu/packages/tryton.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:28 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:30 +0200
commitb5db20a05b820608509c4a125e4ea6b885a5ebe9 (patch)
tree4c8a043746a3fd0f8c124f4e1a5effc75f616f86 /gnu/packages/tryton.scm
parent5f57c127012aa8db2285e4ba99c58e07463e4fe3 (diff)
downloadguix-b5db20a05b820608509c4a125e4ea6b885a5ebe9.tar.gz
gnu: Add trytond-product-price-list-parent.
* gnu/packages/tryton.scm (trytond-product-price-list-parent): New variable.
Diffstat (limited to 'gnu/packages/tryton.scm')
-rw-r--r--gnu/packages/tryton.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 2fe2d0a115..43fa374704 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -2374,6 +2374,30 @@ to compute prices per product or category.")
 date and end date conditions to the price list lines.")
     (license license:gpl3+)))
 
+(define-public trytond-product-price-list-parent
+  (package
+    (name "trytond-product-price-list-parent")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_product_price_list_parent" version))
+       (sha256
+        (base32 "15jdw9qj2fffml9x4vdlzp3iz5gs2l597hpf5y5p887mmx9aa8cn"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "product_price_list_parent"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-product-price-list" ,trytond-product-price-list)))
+    (home-page
+     "https://docs.tryton.org/projects/modules-product-price-list-parent")
+    (synopsis "Tryton module to use price from another price list")
+    (description "The @emph{Product Price List Parent} Tryton module adds a
+parent to the price list and the keyword `parent_unit_price` for the formula
+which contains the unit price computed by the parent price list.")
+    (license license:gpl3+)))
+
 (define-public trytond-purchase
   (package
     (name "trytond-purchase")