summary refs log tree commit diff
path: root/gnu/packages/tryton.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:38 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:32 +0200
commitade7027f0415c8f5b5a4f9375d6c35e86a4a9091 (patch)
treefebf8e44547d508d431d023dcb8b7ecd43873f28 /gnu/packages/tryton.scm
parentec9c9c28cd29239bd413c67c45c1254813f4b5f8 (diff)
downloadguix-ade7027f0415c8f5b5a4f9375d6c35e86a4a9091.tar.gz
gnu: Add trytond-sale-discount.
* gnu/packages/tryton.scm (trytond-sale-discount): New variable.
Diffstat (limited to 'gnu/packages/tryton.scm')
-rw-r--r--gnu/packages/tryton.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 07edc0c008..6a05940b6c 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -3109,6 +3109,29 @@ sale but not yet invoiced to the credit amount of the party and check the
 credit limit of the party when confirming a sale.")
     (license license:gpl3+)))
 
+(define-public trytond-sale-discount
+  (package
+    (name "trytond-sale-discount")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_sale_discount" version))
+       (sha256
+        (base32 "0ss976dcx6k2z2gdbhcgdp6d561b2vwwgf83xdl2pc28q2d3rmh6"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "sale_discount"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-product" ,trytond-product)
+       ("trytond-sale" ,trytond-sale)))
+    (home-page "https://docs.tryton.org/projects/modules-sale-discount")
+    (synopsis "Tryton module that manages discount on sale")
+    (description "The @emph{Sale Discount} Tryton module adds discount on sale
+line.")
+    (license license:gpl3+)))
+
 (define-public trytond-stock
   (package
     (name "trytond-stock")