summary refs log tree commit diff
path: root/gnu/packages/tryton.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2022-07-19 16:37:40 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2022-08-10 14:27:25 +0200
commit4e4c9e064c013e2e3fbccadfcc7e3352683d184d (patch)
tree603ae9e26b99a3a6d16452c23d0747a19645ff58 /gnu/packages/tryton.scm
parentd67e290173007f4ed268fa3c9f8be87e4cc821c4 (diff)
downloadguix-4e4c9e064c013e2e3fbccadfcc7e3352683d184d.tar.gz
gnu: Add trytond-product-image.
* gnu/packages/tryton.scm (trytond-product-image): New variable.
Diffstat (limited to 'gnu/packages/tryton.scm')
-rw-r--r--gnu/packages/tryton.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index ed82a7ebec..833c157689 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -2350,6 +2350,25 @@ and assets.")
 cost price of products to be calculated separately for each warehouse.")
     (license license:gpl3+)))
 
+(define-public trytond-product-image
+  (package
+    (name "trytond-product-image")
+    (version "6.2.1")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "trytond_product_image" version))
+              (sha256
+               (base32 "1xdqgc4y1sghnp5q25facdz3mnaxf8fysqlpbq3zrghsvi136mvd"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "trytond_product_image"))
+    (native-inputs (%standard-trytond-native-inputs))
+    (propagated-inputs (list python-pillow trytond trytond-product))
+    (home-page "https://docs.tryton.org/projects/modules-product-image")
+    (synopsis "Tryton module that adds images to products")
+    (description "The @emph{Product Image} Tryton module adds images to each
+product and variant.")
+    (license license:gpl3+)))
+
 (define-public trytond-product-kit
   (package
     (name "trytond-product-kit")