summary refs log tree commit diff
path: root/gnu/packages/tryton.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:26 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:29 +0200
commit09ec25e3facae44a3605fb9b7124ddd920afb7c1 (patch)
tree5be71787dfda7406e68fd62f0e6e702db304e754 /gnu/packages/tryton.scm
parentca8b6b5a641dab4869dd6c522847cb875e7d47fd (diff)
downloadguix-09ec25e3facae44a3605fb9b7124ddd920afb7c1.tar.gz
gnu: Add trytond-product-cost-history.
* gnu/packages/tryton.scm (trytond-product-cost-history): New variable.
Diffstat (limited to 'gnu/packages/tryton.scm')
-rw-r--r--gnu/packages/tryton.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index e9b7c8a984..28adde6eeb 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -2217,6 +2217,33 @@ adds the taxonomic classification to the products.")
 first-in-first-out option in the `Cost Method` field of the product form.")
     (license license:gpl3+)))
 
+(define-public trytond-product-cost-history
+  (package
+    (name "trytond-product-cost-history")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_product_cost_history" version))
+       (sha256
+        (base32 "01cxx1lmcxwangk3q8lhbkd97w208qxpk96mqxv2hgds77xr42cj"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "product_cost_history"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-product" ,trytond-product)
+       ("trytond-stock" ,trytond-stock)))
+    (home-page "https://docs.tryton.org/projects/modules-product-cost-history")
+    (synopsis "Tryton module to historize product cost")
+    (description "The @emph{Product Cost History} Tryton module adds a `Cost
+History` relate on the product form, showing the cost price evolution of the
+product.  The history is based on the cost price stored on the incoming stock
+moves for goods and assets and based on the history table for service.  When a
+historic cost price is needed, the value is taken from this history for goods
+and assets.")
+    (license license:gpl3+)))
+
 (define-public trytond-purchase
   (package
     (name "trytond-purchase")