summary refs log tree commit diff
path: root/gnu/packages/tryton.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:25 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:29 +0200
commitca8b6b5a641dab4869dd6c522847cb875e7d47fd (patch)
tree90b8136bd919c822c55cac983f41321fbd002e6a /gnu/packages/tryton.scm
parent96afaa0452de5f9fe7883ad71a4e2910a7167f52 (diff)
downloadguix-ca8b6b5a641dab4869dd6c522847cb875e7d47fd.tar.gz
gnu: Add trytond-product-cost-fifo.
* gnu/packages/tryton.scm (trytond-product-cost-fifo): New variable.
Diffstat (limited to 'gnu/packages/tryton.scm')
-rw-r--r--gnu/packages/tryton.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 36bbecf976..e9b7c8a984 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -2194,6 +2194,29 @@ reference field classification to the product template.")
 adds the taxonomic classification to the products.")
     (license license:gpl3+)))
 
+(define-public trytond-product-cost-fifo
+  (package
+    (name "trytond-product-cost-fifo")
+    (version "6.0.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_product_cost_fifo" version))
+       (sha256
+        (base32 "1zksnawvnbf1l2hkyxw4m85ysjy6i8kbx103sz4p9a9bgvjn3ai6"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "product_cost_fifo"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-product" ,trytond-product)
+       ("trytond-stock" ,trytond-stock)))
+    (home-page "https://docs.tryton.org/projects/modules-product-cost-fifo")
+    (synopsis "Tryton module to add FIFO cost method")
+    (description "The @emph{Product Cost FIFO} Tryton module add a
+first-in-first-out option in the `Cost Method` field of the product form.")
+    (license license:gpl3+)))
+
 (define-public trytond-purchase
   (package
     (name "trytond-purchase")