summary refs log tree commit diff
path: root/gnu/packages/tryton.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:38 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:31 +0200
commite515d2891c78186f937d74f1d4af2bf32978aa89 (patch)
tree72558939c811a9377650166ee88b005521384032 /gnu/packages/tryton.scm
parent725a31725df3c73691198c30384a01fc4806d821 (diff)
downloadguix-e515d2891c78186f937d74f1d4af2bf32978aa89.tar.gz
gnu: Add trytond-sale-complaint.
* gnu/packages/tryton.scm (trytond-sale-complaint): New variable.
Diffstat (limited to 'gnu/packages/tryton.scm')
-rw-r--r--gnu/packages/tryton.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 8f96ecab4e..7661dc5149 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -3057,6 +3057,31 @@ sales that are being processed and keep track of the changes.  An amendment is
 composed of action lines which can:")
     (license license:gpl3+)))
 
+(define-public trytond-sale-complaint
+  (package
+    (name "trytond-sale-complaint")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_sale_complaint" version))
+       (sha256
+        (base32 "0wbs7kawrzz39z0jw34ygdb85qja49xfb75ahbwgqd185wf3jvgz"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "sale_complaint"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-account-invoice" ,trytond-account-invoice)
+       ("trytond-company" ,trytond-company)
+       ("trytond-party" ,trytond-party)
+       ("trytond-sale" ,trytond-sale)))
+    (home-page "https://docs.tryton.org/projects/modules-sale-complaint")
+    (synopsis "Tryton module for sale complaints")
+    (description "The @emph{Sale Complaint} Tryton module defines the
+@code{Complaint} model.")
+    (license license:gpl3+)))
+
 (define-public trytond-stock
   (package
     (name "trytond-stock")