summary refs log tree commit diff
path: root/gnu/packages/tryton.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:18 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:28 +0200
commita22db49e5e87d7731ceba012988715f20eeb9640 (patch)
tree0d18845e4e9b7f955fca62d4a841eb6fa8d87110 /gnu/packages/tryton.scm
parenta0b153dcd12dbc0edc0300f38b10b567b4447eb9 (diff)
downloadguix-a22db49e5e87d7731ceba012988715f20eeb9640.tar.gz
gnu: Add trytond-company-work-time.
* gnu/packages/tryton.scm (trytond-company-work-time): New variable.
Diffstat (limited to 'gnu/packages/tryton.scm')
-rw-r--r--gnu/packages/tryton.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index c6e5da81f9..3f8920b30f 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -1654,6 +1654,33 @@ company and employee and extend the user model.")
 (define-public python-trytond-company
   (deprecated-package "python-trytond-company" trytond-company))
 
+(define-public trytond-company-work-time
+  (package
+    (name "trytond-company-work-time")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_company_work_time" version))
+       (sha256
+        (base32 "0aasp12l66zcys9w3qc4ysi2krd5c9x3xxaxvr29j7zl7nz05bwx"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "company_work_time"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-company" ,trytond-company)))
+    (home-page "https://docs.tryton.org/projects/modules-company-work-time")
+    (synopsis "Tryton module to add work time on company")
+    (description "The @emph{Company Work Time} Tryton module adds work time
+management.
+
+The Company Work Time module adds 4 new fields (Hours per Work Day, Hours per
+Work Week, Hours per Work Month, Hours per Work Year) on the company form that
+allow to define how much hours are spent by an employee in a day, a week, a
+month and a year of work.")
+    (license license:gpl3+)))
+
 (define-public trytond-country
   (package
     (name "trytond-country")