summary refs log tree commit diff
path: root/gnu/packages/tryton.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2020-08-24 19:20:18 -0300
committerMathieu Othacehe <othacehe@gnu.org>2020-08-25 16:00:18 +0200
commit06d206a76d338739c96872dc749c2f3b33042887 (patch)
treebf1ae390e83ad5f6d4ad8f4919a4dccc76cfbe7c /gnu/packages/tryton.scm
parent6844d36443c46e42e9f4d159ff2f6c541494676c (diff)
downloadguix-06d206a76d338739c96872dc749c2f3b33042887.tar.gz
gnu: Add python-trytond-stock-lot.
* gnu/packages/tryton.scm (python-trytond-stock-lot): New variable.

Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/tryton.scm')
-rw-r--r--gnu/packages/tryton.scm48
1 files changed, 48 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index d88a559260..7cde0db7ea 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -468,6 +468,54 @@ between these locations, shipments for product arrivals and departures and
 inventory to control and update stock levels.")
     (license license:gpl3+)))
 
+(define-public python-trytond-stock-lot
+  (package
+    (name "python-trytond-stock-lot")
+    (version "5.6.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_stock_lot" version))
+       (sha256
+        (base32 "0a0kc8dyx2zw244dhq6lm2jdp1kzpllhdhrmx7kkr9cjhp58rqip"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (let ((runtest
+                  (string-append
+                   (assoc-ref %build-inputs "python-trytond")
+                   "/lib/python"
+                   ,(version-major+minor (package-version python))
+                   "/site-packages/trytond/tests/run-tests.py")))
+             (lambda* (#:key inputs outputs #:allow-other-keys)
+               (add-installed-pythonpath inputs outputs)
+               (invoke "python" runtest "-m" "stock_lot")))))))
+    (native-inputs
+     `(("python" ,python)
+       ("python-dateutil" ,python-dateutil)
+       ("python-genshi" ,python-genshi)
+       ("python-lxml" ,python-lxml)
+       ("python-magic" ,python-magic)
+       ("python-passlib" ,python-passlib)
+       ("python-polib" ,python-polib)
+       ("python-proteus" ,python-proteus)
+       ("python-relatorio" ,python-relatorio)
+       ("python-sql" ,python-sql)
+       ("python-werkzeug" ,python-werkzeug)
+       ("python-wrapt" ,python-wrapt)))
+    (propagated-inputs
+     `(("python-trytond" ,python-trytond)
+       ("python-trytond-product"
+        ,python-trytond-product)
+       ("python-trytond-stock" ,python-trytond-stock)))
+    (home-page "https://www.tryton.org/")
+    (synopsis "Tryton module for lot of products")
+    (description
+     "This package provides a Tryton module that defines lot of products.")
+    (license license:gpl3+)))
+
 (define-public python-proteus
   (package
     (name "python-proteus")