summary refs log tree commit diff
path: root/gnu/packages/tryton.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:25 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:29 +0200
commit96afaa0452de5f9fe7883ad71a4e2910a7167f52 (patch)
tree47734e71f7b8cde122967f6de917d290ccf73536 /gnu/packages/tryton.scm
parenta7a084fbffee4fb64111726c5b299495a9760d79 (diff)
downloadguix-96afaa0452de5f9fe7883ad71a4e2910a7167f52.tar.gz
gnu: Add trytond-product-classification-taxonomic.
* gnu/packages/tryton.scm (trytond-product-classification-taxonomic): New variable.
Diffstat (limited to 'gnu/packages/tryton.scm')
-rw-r--r--gnu/packages/tryton.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index dd8b6d51fc..36bbecf976 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -2171,6 +2171,29 @@ tools for other modules to create classifications of products.  It adds a
 reference field classification to the product template.")
     (license license:gpl3+)))
 
+(define-public trytond-product-classification-taxonomic
+  (package
+    (name "trytond-product-classification-taxonomic")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_product_classification_taxonomic" version))
+       (sha256
+        (base32 "1pkk0z4bl1pz2yxs46b18fj35zwa80dnbickjg1ad66n9yrmifk6"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "product_classification_taxonomic"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-product-classification" ,trytond-product-classification)))
+    (home-page
+     "https://docs.tryton.org/projects/modules-product-classification-taxonomic")
+    (synopsis "Tryton module to implement product classification taxonomic")
+    (description "The @emph{Product Classification Taxonomic} Tryton module
+adds the taxonomic classification to the products.")
+    (license license:gpl3+)))
+
 (define-public trytond-purchase
   (package
     (name "trytond-purchase")