summary refs log tree commit diff
path: root/gnu/packages/tryton.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:33 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:31 +0200
commitc7d42009c112572f481aa8ce83bd39f40fdeee9c (patch)
treed2878f6f75ff064a42c39a450b51b0e8c3bd91ad /gnu/packages/tryton.scm
parent218c16095b7c81d8eb06b506cd56025f5af27856 (diff)
downloadguix-c7d42009c112572f481aa8ce83bd39f40fdeee9c.tar.gz
gnu: Add trytond-purchase-amendment.
* gnu/packages/tryton.scm (trytond-purchase-amendment): New variable.
Diffstat (limited to 'gnu/packages/tryton.scm')
-rw-r--r--gnu/packages/tryton.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 60eada82bc..b62d7c00c5 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -2702,6 +2702,42 @@ the linked time sheets and the linked purchase lines.")
 (define-public python-trytond-purchase
   (deprecated-package "python-trytond-purchase" trytond-purchase))
 
+(define-public trytond-purchase-amendment
+  (package
+    (name "trytond-purchase-amendment")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_purchase_amendment" version))
+       (sha256
+        (base32 "0bgk5ib7y1nzdrfx00g9qr2lxmjkascvh1caps21r12czz0iz5fx"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "purchase_amendment"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-account-invoice" ,trytond-account-invoice)
+       ("trytond-purchase" ,trytond-purchase)
+       ("trytond-purchase-history" ,trytond-purchase-history)
+       ("trytond-stock" ,trytond-stock)))
+    (home-page "https://docs.tryton.org/projects/modules-purchase-amendment")
+    (synopsis "Tryton module to amend purchases")
+    (description "The @emph{Purchase Amendment} Tryton module allows you to
+change purchases that are being processed and keep track of the changes.  An
+amendment is composed of action lines which can:
+
+@itemize
+@item recompute taxes (if the supplier tax rules or product taxes have
+      changed),
+@item change the payment term,
+@item change the party and the address,
+@item change the warehouse, or
+@item change a purchase line: (product, quantity and unit of measure,
+      unit price or description).
+@end itemize")
+    (license license:gpl3+)))
+
 (define-public trytond-purchase-request
   (package
     (name "trytond-purchase-request")