summary refs log tree commit diff
path: root/gnu/packages/valgrind.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-06-27 12:16:17 +0200
committerMarius Bakke <marius@gnu.org>2020-06-27 12:29:24 +0200
commitb611597af8641b388dc9f8935b85895a71e9fb52 (patch)
tree435aeb6a82d25414cdbe6a48a1ed4cdc3e4ec353 /gnu/packages/valgrind.scm
parentac069ed9be60defd1690e0e5756e74d2271c39cb (diff)
downloadguix-b611597af8641b388dc9f8935b85895a71e9fb52.tar.gz
gnu: valgrind: Don't depend on GDB.
...but add a special 'valgrind/interactive' variant for end users.

* gnu/packages/valgrind.scm (valgrind)[inputs]: Remove.
[properties]: New field.
(valgrind/interactive): New public variable.
Diffstat (limited to 'gnu/packages/valgrind.scm')
-rw-r--r--gnu/packages/valgrind.scm17
1 files changed, 13 insertions, 4 deletions
diff --git a/gnu/packages/valgrind.scm b/gnu/packages/valgrind.scm
index 75e852915e..c0ea89141e 100644
--- a/gnu/packages/valgrind.scm
+++ b/gnu/packages/valgrind.scm
@@ -4,6 +4,7 @@
 ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
 ;;; Copyright © 2016, 2020 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -70,9 +71,6 @@
                (mkdir-p dest)
                (rename-file orig dest)
                #t))))))
-    (inputs
-     ;; GDB is needed to provide a sane default for `--db-command'.
-     `(("gdb" ,gdb)))
     (native-inputs
      `(("perl" ,perl)))
     (home-page "https://www.valgrind.org/")
@@ -82,4 +80,15 @@
 tools.  There are Valgrind tools that can automatically detect many memory
 management and threading bugs, and profile your programs in detail.  You can
 also use Valgrind to build new tools.")
-    (license gpl2+)))
+    (license gpl2+)
+
+    ;; Hide this variant so end users get the "interactive" Valgrind below.
+    (properties '((hidden? . #t)))))
+
+(define-public valgrind/interactive
+  (package/inherit
+   valgrind
+   (inputs
+    ;; GDB is needed to provide a sane default for `--db-command'.
+    `(("gdb" ,gdb)))
+   (properties '())))