summary refs log tree commit diff
path: root/gnu/packages/valgrind.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2023-05-25 09:45:02 +0100
committerChristopher Baines <mail@cbaines.net>2023-05-25 09:45:02 +0100
commite5184ba4349a66db24c5723c5a29befca6bcd338 (patch)
tree49389ecd25055b77e4d5f49fd689feaa3537d565 /gnu/packages/valgrind.scm
parent36c72c1595f1cb0a50128ab9e59d5765b0648ffa (diff)
downloadguix-e5184ba4349a66db24c5723c5a29befca6bcd338.tar.gz
gnu: valgrind: Mark as not supported for armhf-linux.
From the build log:
  checking for a supported CPU... no (arm)
  configure: error: Unsupported host architecture. Sorry

* gnu/packages/valgrind.scm (valgrind)[supported-systems]: Remove armhf-linux.
Diffstat (limited to 'gnu/packages/valgrind.scm')
-rw-r--r--gnu/packages/valgrind.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/valgrind.scm b/gnu/packages/valgrind.scm
index 7203745034..ee39bb2fb0 100644
--- a/gnu/packages/valgrind.scm
+++ b/gnu/packages/valgrind.scm
@@ -24,6 +24,7 @@
 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
 
 (define-module (gnu packages valgrind)
+  #:use-module (srfi srfi-1)
   #:use-module (guix build-system gnu)
   #:use-module (guix download)
   #:use-module (guix gexp)
@@ -83,7 +84,8 @@ tools.  There are Valgrind tools that can automatically detect many memory
 management and threading bugs, and profile your programs in detail.  You can
 also use Valgrind to build new tools.")
     ;; https://valgrind.org/info/platforms.html
-    (supported-systems (delete "riscv64-linux" %supported-systems))
+    (supported-systems (fold delete %supported-systems
+                             '("armhf-linux" "riscv64-linux")))
     (license gpl2+)
 
     ;; Hide this variant so end users get the "interactive" Valgrind below.