summary refs log tree commit diff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-01-15 23:00:11 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-01-15 23:02:11 +0100
commit03d76f8a42996cca3f0604a3ae9a8fe289a940ed (patch)
tree3cb06c1df3e3613b27d1a2744fa73082c980bc8a /gnu/packages/version-control.scm
parent1fffba664d71f3a8669b5eefd2c4a83dca5bacce (diff)
downloadguix-03d76f8a42996cca3f0604a3ae9a8fe289a940ed.tar.gz
gnu: mercurial: Raise test time-outs.
Let Guix handle them.  Fixes <https://paste.debian.net/plain/1126159>.

* gnu/packages/version-control.scm (mercurial)[arguments]:
Raise individual test time-outs to 1 day.
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 5403bcf87a..417bccf99b 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -1269,6 +1269,10 @@ control to Git repositories.")
                          ;; ‘make check’ does not respect ‘-j’.
                          (string-append "-j" (number->string
                                               (parallel-job-count)))
+                         ;; The default time-outs are too low for many systems.
+                         ;; Raise them generously: Guix enforces its own.
+                         "--timeout" "86400"
+                         "--slowtimeout" "86400"
                          ;; The test suite takes a long time and produces little
                          ;; output by default.  Prevent timeouts due to silence.
                          "-v"))