summary refs log tree commit diff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-08-14 23:31:37 -0400
committerLeo Famulari <leo@famulari.name>2017-08-15 17:59:22 -0400
commit8343d373d5038d230652a51190f6a7c986674df6 (patch)
treef2fc2f2162aee639ab3ca047173d94b39b366ebf /gnu/packages/version-control.scm
parent6230e155afd8c43c12ee3f03032aac34433db11a (diff)
downloadguix-8343d373d5038d230652a51190f6a7c986674df6.tar.gz
gnu: cgit: Don't build cgit's special 'git:src' input.
This special version of Git is only used within the build process of
cgit. We don't need to build it otherwise, so the package is removed
with this commit.

* gnu/packages/version-control.scm (cgit)[inputs]: Replace the git@2.10
package with an origin reference of the source code.
(git@2.10): Remove variable.
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm34
1 files changed, 15 insertions, 19 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 7c1f02d5ad..869672ca45 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -9,7 +9,7 @@
 ;;; Copyright © 2015, 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2015 Kyle Meyer <kyle@kyleam.com>
 ;;; Copyright © 2015, 2017 Ricardo Wurmus <rekado@elephly.net>
-;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2016, 2017 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2016, 2017 ng0 <contact.ng0@cryptolab.net>
 ;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2017 Vasile Dumitrascu <va511e@yahoo.com>
@@ -121,6 +121,8 @@ as well as the classic centralized workflow.")
 (define-public git
   (package
    (name "git")
+   ;; XXX When updating Git, check if the special 'git:src' input to cgit needs
+   ;; to be updated as well.
    (version "2.14.1")
    (source (origin
             (method url-fetch)
@@ -349,23 +351,6 @@ everything from small to very large projects with speed and efficiency.")
    (license license:gpl2)
    (home-page "https://git-scm.com/")))
 
-;; Some dependent packages directly access internal interfaces which
-;; have changed in 2.12. TODO: Remove this for cgit > 1.1.
-(define-public git@2.10
-  (package
-    (inherit git)
-    (version "2.10.4")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append "mirror://kernel.org/software/scm/git/git-"
-                                  version ".tar.xz"))
-              (sha256
-               (base32
-                "1pni4mgih5w42813dxljl61s7xmcpdnar34d9m4548hzpljjyd4l"))))
-    (arguments
-     `(#:tests? #f
-       ,@(package-arguments git)))))
-
 (define-public libgit2
   (package
     (name "libgit2")
@@ -502,6 +487,8 @@ collaboration using typical untrusted file hosts or services.")
 (define-public cgit
   (package
     (name "cgit")
+    ;; XXX When updating cgit, try removing the special 'git:src' input and
+    ;; using the source of the git package.
     (version "1.1")
     (source (origin
               (method url-fetch)
@@ -546,7 +533,16 @@ collaboration using typical untrusted file hosts or services.")
      ;; For building manpage.
      `(("asciidoc" ,asciidoc)))
     (inputs
-     `(("git:src" ,(package-source git@2.10))
+     `(;; Cgit directly accesses some internal Git interfaces that changed in
+       ;; Git 2.12.  Try removing this special input and using the source of the
+       ;; Git package for cgit > 1.1.
+       ("git:src"
+        ,(origin
+           (method url-fetch)
+           (uri "mirror://kernel.org/software/scm/git/git-2.10.4.tar.xz")
+           (sha256
+            (base32
+             "1pni4mgih5w42813dxljl61s7xmcpdnar34d9m4548hzpljjyd4l"))))
        ("openssl" ,openssl)
        ("zlib" ,zlib)))
     (home-page "https://git.zx2c4.com/cgit/")