summary refs log tree commit diff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-08-09 17:42:14 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-08-09 20:19:05 +0300
commit1d5d115e76b39065acc9406a23d44adfb8f7d7e1 (patch)
tree68b61012a9fdab2f77019051dbab3d564f0381da /gnu/packages/version-control.scm
parent5b6ac91ee4cd44df599f1e55156aa5e362da6d66 (diff)
downloadguix-1d5d115e76b39065acc9406a23d44adfb8f7d7e1.tar.gz
gnu: Remove python-distutils/next.
* gnu/packages/python-xyz.scm (python-distutils/next): Remove variable.
(python-virtualenv)[propagated-inputs]: Switch from
python-distutils/next to python-distutils.
* gnu/packages/version-control.scm (pre-commit)[inputs]: Same.
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm10
1 files changed, 4 insertions, 6 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 8bdac8df53..709ddadf64 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -1560,16 +1560,14 @@ control to Git repositories.")
                        ;; Ruby and Node tests require node and gem.
                        "--ignore=tests/languages/node_test.py"
                        "--ignore=tests/languages/ruby_test.py"
-                       ;; FIXME: Python tests fail because of distlib version
-                       ;; mismatch.  Even with python-distlib/next it is
-                       ;; pulling version 0.3.0, while 0.3.1 is required.
-                       "--ignore=tests/languages/python_test.py" "-k"
+                       "-k"
                        (string-append
                         ;; TODO: these tests fail with AssertionError.  It may
                         ;; be possible to fix them.
                         "not test_install_existing_hooks_no_overwrite"
                         " and not test_uninstall_restores_legacy_hooks"
-                        " and not test_installed_from_venv")))))
+                        " and not test_installed_from_venv"
+                        " and not test_healthy_venv_creator")))))
          (add-before 'reset-gzip-timestamps 'make-gz-writable
            (lambda* (#:key outputs #:allow-other-keys)
              ;; Make sure .gz files are writable so that the
@@ -1581,7 +1579,7 @@ control to Git repositories.")
      `(("git" ,git-minimal)
        ("python-covdefaults" ,python-covdefaults)
        ("python-coverage" ,python-coverage)
-       ("python-distlib" ,python-distlib/next)
+       ("python-distlib" ,python-distlib)
        ("python-pytest" ,python-pytest)
        ("python-pytest-env" ,python-pytest-env)
        ("python-re-assert" ,python-re-assert)