summary refs log tree commit diff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-07-22 15:52:35 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-07-22 18:24:22 +0300
commit7c5a1454144cafb37c0aa2844bc4d258bb69c413 (patch)
tree44a02beb6a32850f69e8d7ddbf36a03ba25a892b /gnu/packages/version-control.scm
parentce84c924ac0b537aba83936a124e13c6bafb0a2a (diff)
downloadguix-7c5a1454144cafb37c0aa2844bc4d258bb69c413.tar.gz
gnu: subversion: Use 'modify-phases'.
* gnu/packages/version-control.scm (subversion)[arguments]: Use
'modify-phases'.
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm65
1 files changed, 31 insertions, 34 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 51be56c150..705f24194a 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -692,41 +692,38 @@ property manipulation.")
                "0imkxn25n6sbcgfldrx4z29npjprb1lxjm5fb89q4297161nx3zi"))))
     (build-system gnu-build-system)
     (arguments
-     '(#:phases (alist-cons-after
-                 'configure 'patch-libtool-wrapper-ls
-                 (lambda* (#:key inputs #:allow-other-keys)
-                   ;; This substitution allows tests svnauthz_tests and
-                   ;; svnlook_tests to pass.  These tests execute svnauthz and
-                   ;; svnlook through their libtool wrapper scripts from svn
-                   ;; hooks, whose empty environments cause "ls: command not
-                   ;; found" errors.  It would be nice if this fix ultimately
-                   ;; made its way into libtool.
-                   (let ((coreutils (assoc-ref inputs "coreutils")))
-                     (substitute* "libtool"
-                       (("\\\\`ls") (string-append "\\`" coreutils "/bin/ls")))))
-                 (alist-cons-after
-                  'install 'install-perl-bindings
-                  (lambda* (#:key outputs #:allow-other-keys)
-                    ;; Follow the instructions from
-                    ;; 'subversion/bindings/swig/INSTALL'.
-                    (let ((out (assoc-ref outputs "out")))
-                      (and (zero? (system* "make" "swig-pl-lib"))
-                           ;; FIXME: Test failures.
-                           ;; (zero? (system* "make" "check-swig-pl"))
-                           (zero? (system* "make" "install-swig-pl-lib"))
+     '(#:phases
+       (modify-phases %standard-phases
+         (add-after 'configure 'patch-libtool-wrapper-ls
+           (lambda* (#:key inputs #:allow-other-keys)
+             ;; This substitution allows tests svnauthz_tests and svnlook_tests
+             ;; to pass.  These tests execute svnauthz and svnlook through
+             ;; their libtool wrapper scripts from svn hooks, whose empty
+             ;; environments cause "ls: command not found" errors.  It would be
+             ;; nice if this fix ultimately made its way into libtool.
+             (let ((coreutils (assoc-ref inputs "coreutils")))
+               (substitute* "libtool"
+                 (("\\\\`ls") (string-append "\\`" coreutils "/bin/ls"))))))
+         (add-after 'install 'install-perl-bindings
+           (lambda* (#:key outputs #:allow-other-keys)
+             ;; Follow the instructions from 'subversion/bindings/swig/INSTALL'.
+             (let ((out (assoc-ref outputs "out")))
+               (and (zero? (system* "make" "swig-pl-lib"))
+                    ;; FIXME: Test failures.
+                    ;; (zero? (system* "make" "check-swig-pl"))
+                    (zero? (system* "make" "install-swig-pl-lib"))
 
-                           ;; Set the right installation prefix.
-                           (with-directory-excursion
-                               "subversion/bindings/swig/perl/native"
-                             (and (zero?
-                                   (system* "perl" "Makefile.PL"
-                                            (string-append "PREFIX=" out)))
-                                  (zero?
-                                   (system* "make" "install"
-                                            (string-append "OTHERLDFLAGS="
-                                                           "-Wl,-rpath="
-                                                           out "/lib"))))))))
-                  %standard-phases))))
+                    ;; Set the right installation prefix.
+                    (with-directory-excursion
+                        "subversion/bindings/swig/perl/native"
+                      (and (zero?
+                            (system* "perl" "Makefile.PL"
+                                     (string-append "PREFIX=" out)))
+                           (zero?
+                            (system* "make" "install"
+                                     (string-append "OTHERLDFLAGS="
+                                                    "-Wl,-rpath="
+                                                    out "/lib"))))))))))))
     (native-inputs
       `(("pkg-config" ,pkg-config)
         ;; For the Perl bindings.