summary refs log tree commit diff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-09-29 16:57:50 +0200
committerLudovic Courtès <ludo@gnu.org>2013-09-29 17:30:30 +0200
commit8b2fe7853d6b81f8a2b334b7f8f0af929194c2de (patch)
tree368063a834900036ebf5d68591fe3dd40f46cb8a /gnu/packages/version-control.scm
parent832e64bddac744fde7e2c2d3f8c8e47400d65b76 (diff)
downloadguix-8b2fe7853d6b81f8a2b334b7f8f0af929194c2de.tar.gz
gnu: subversion: Install Perl bindings.
* gnu/packages/version-control.scm (subversion): Add
  'install-perl-bindings' phase.
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm27
1 files changed, 26 insertions, 1 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 42b5d5fe99..8a0242cfd4 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -38,7 +38,8 @@
   #:use-module (gnu packages system)
   #:use-module (gnu packages xml)
   #:use-module (gnu packages emacs)
-  #:use-module (gnu packages compression))
+  #:use-module (gnu packages compression)
+  #:use-module (gnu packages swig))
 
 (define-public bazaar
   (package
@@ -124,6 +125,30 @@ everything from small to very large projects with speed and efficiency.")
               (base32
                "11inl9n1riahfnbk1fax0dysm2swakzhzhpmm2zvga6fikcx90zw"))))
     (build-system gnu-build-system)
+    (arguments
+     '(#:phases (alist-cons-after
+                 'install 'instal-perl-bindings
+                 (lambda* (#:key outputs #:allow-other-keys)
+                   ;; Follow the instructions from
+                   ;; 'subversion/bindings/swig/INSTALL'.
+                   (let ((out (assoc-ref outputs "out")))
+                     (and (zero? (system* "make" "swig-pl-lib"))
+                          ;; FIXME: Test failures.
+                          ;; (zero? (system* "make" "check-swig-pl"))
+                          (zero? (system* "make" "install-swig-pl-lib"))
+
+                          ;; Set the right installation prefix.
+                          (with-directory-excursion
+                              "subversion/bindings/swig/perl/native"
+                            (and (zero?
+                                  (system* "perl" "Makefile.PL"
+                                           (string-append "PREFIX=" out)))
+                                 (zero?
+                                  (system* "make" "install")))))))
+                 %standard-phases)))
+    (native-inputs
+      ;; For the Perl bindings.
+      `(("swig" ,swig)))
     (inputs
       `(("apr" ,apr)
         ("apr-util" ,apr-util)