summary refs log tree commit diff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-10-23 17:41:55 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-10-23 17:45:55 +0300
commitd24e37f36e2a89c0613bf5064e59b9236bca2ae1 (patch)
tree9a0f93707bceea6ea3af069cfe19c250975dc6d1 /gnu/packages/version-control.scm
parent69e08c14f921aedde5a759b91d4ba8e5b150c14b (diff)
downloadguix-d24e37f36e2a89c0613bf5064e59b9236bca2ae1.tar.gz
gnu: rcs: Update to 5.10.0.
* gnu/packages/version-control.scm (rcs): Update to 5.10.0.
[source]: Update patches.
[arguments]: Remove field.
* gnu/packages/patches/rcs-5.9.4-noreturn.patch: Remove file.
* gnu/packages/patches/rcs-5.10.0-no-stdin.patch: Add file.
* gnu/local.mk (dist_patch_DATA): Register changes.
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm15
1 files changed, 3 insertions, 12 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index fe61bc8fce..0e0e59d1a2 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -1799,26 +1799,17 @@ projects, from individuals to large-scale enterprise operations.")
 (define-public rcs
   (package
     (name "rcs")
-    (version "5.9.4")
+    (version "5.10.0")
     (source (origin
              (method url-fetch)
              (uri (string-append "mirror://gnu/rcs/rcs-"
                                  version ".tar.xz"))
              (sha256
               (base32
-               "1zsx7bb0rgvvvisiy4zlixf56ay8wbd9qqqcp1a1g0m1gl6mlg86"))
-             (patches (search-patches "rcs-5.9.4-noreturn.patch"))))
+               "1if5pa4iip2p70gljm54nggfdnsfjxa4cqz8fpj07lvsijary39s"))
+             (patches (search-patches "rcs-5.10.0-no-stdin.patch"))))
     (build-system gnu-build-system)
     (native-inputs `(("ed" ,ed)))
-    (arguments
-     `(#:phases (modify-phases %standard-phases
-                  (add-before 'check 'disable-t810
-                    ;; See https://savannah.gnu.org/bugs/index.php?52288
-                    ;; Back-porting the fix is non-trivial, so disable for now.
-                    (lambda _
-                      (substitute* "tests/Makefile"
-                        ((" t810 \\\\\n") ""))
-                     #t)))))
     (home-page "https://www.gnu.org/software/rcs/")
     (synopsis "Per-file local revision control system")
     (description