summary refs log tree commit diff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-05-08 10:32:28 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-28 13:12:34 +0300
commita1c16fe055f79b3363f0b878e7ed3ef97ce108a4 (patch)
treec6e8d5f6948eee79bb0cfc79af14851d63bb834c /gnu/packages/version-control.scm
parent2073218ef6a0d49260491c2922383375c7b590a8 (diff)
downloadguix-a1c16fe055f79b3363f0b878e7ed3ef97ce108a4.tar.gz
gnu: mercurial: Skip tests on powerpc-linux.
* gnu/packages/version-control.scm (mercurial)[arguments]: Skip tests on
powerpc-linux.
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 580f124f71..54c949555a 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -1676,7 +1676,12 @@ execution of any hook written in any language before every commit.")
                          "--slowtimeout" "86400"
                          ;; The test suite takes a long time and produces little
                          ;; output by default.  Prevent timeouts due to silence.
-                         "-v"))))))))
+                         "-v"))))))
+       ;; Tests on powerpc-linux take more than 10 hours.
+       #:tests? ,(if (string=? "powerpc-linux" (or (%current-system)
+                                                   (%current-target-system)))
+                   #f #t)))
+    ;; The following inputs are only needed to run the tests.
     (native-inputs
      `(("python-docutils", python-docutils)
        ;; The following inputs are only needed to run the tests.