summary refs log tree commit diff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorJosselin Poiret <dev@jpoiret.xyz>2023-12-27 11:15:22 +0100
committerHilton Chain <hako@ultrarare.space>2024-02-01 14:20:16 +0800
commitee20e6fa2ee7c607eac9095f5e2fd00c0aa3d7ab (patch)
tree65ada358c6263630fc0610ad554094e9ecf0b0eb /gnu/packages/video.scm
parent95c2de71a4bc2417090efa7af0f59dd7ed5675b6 (diff)
downloadguix-ee20e6fa2ee7c607eac9095f5e2fd00c0aa3d7ab.tar.gz
gnu: mpv-mpris: Switch to gnu-build-system.
* gnu/packages/video.scm (mpv-mpris)[build-system]: Use gnu-build-system again.
[arguments]<#:phases>: Run tests.
[native-inputs]: Add dbus, jq, playerctl, socat, sound-theme-freedesktop,
xorg-server-for-tests, xvfb-run.

Change-Id: I9de4ade633388ec42ac30019feb133ca98811ad9
Signed-off-by: Hilton Chain <hako@ultrarare.space>
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm38
1 files changed, 28 insertions, 10 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index b182b2d9f3..ef69c1dcc8 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -154,6 +154,7 @@
   #:use-module (gnu packages image)
   #:use-module (gnu packages imagemagick)
   #:use-module (gnu packages iso-codes)
+  #:use-module (gnu packages libcanberra)
   #:use-module (gnu packages libidn)
   #:use-module (gnu packages libusb)
   #:use-module (gnu packages linux)
@@ -2785,18 +2786,35 @@ images and image hosting sites.")
         (file-name (git-file-name name version))
         (sha256
          (base32 "1384y8n3l0xk8hbad1nsj9ljzb1h02g3ln3jysd8bd6shbl0x4mx"))))
-    (build-system copy-build-system)
+    (build-system gnu-build-system)
     (arguments
-     '(#:install-plan
-       '(("mpris.so" "lib/"))
-       #:phases
-       (modify-phases %standard-phases
-         (add-before 'install 'build
-           (lambda _
-             (setenv "CC" (which "gcc"))
-             (invoke "make"))))))
+     (list
+      #:make-flags
+      #~(list (string-append "SCRIPTS_DIR=" #$output "/lib")
+              (string-append "CC=" #$(cc-for-target)))
+      #:phases
+      #~(modify-phases %standard-phases
+          (delete 'configure)
+          (replace 'check
+            (lambda* (#:key inputs native-inputs tests? #:allow-other-keys)
+              (if tests?
+                  (begin
+                    (setenv
+                     "MPV_MPRIS_TEST_PLAY"
+                     (search-input-file
+                      (or native-inputs inputs)
+                      "share/sounds/freedesktop/stereo/alarm-clock-elapsed.oga"))
+                    (invoke "make" "test"))
+                  (format #t "test suite not run~%")))))))
     (native-inputs
-     (list pkg-config))
+     (list dbus
+           jq
+           pkg-config
+           playerctl
+           socat
+           sound-theme-freedesktop
+           xorg-server-for-tests
+           xvfb-run))
     (inputs
      (list ffmpeg glib mpv))
     (home-page "https://github.com/hoyon/mpv-mpris")