summary refs log tree commit diff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-03-10 13:55:07 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-03-18 00:19:55 +0100
commit3993a28a36593187dde94c88b55d75ce12175fa7 (patch)
tree1d1a65ef2c10c4072363552eefe988f7fe9f86f2 /gnu/packages/video.scm
parentbe56161df16b7a6e72c88ff3a21177485fd93580 (diff)
downloadguix-3993a28a36593187dde94c88b55d75ce12175fa7.tar.gz
gnu: Switch from dri2proto to xorgproto.
* gnu/packages/gl.scm (mesa)[inputs]: Remove DRI2PROTO.
* gnu/packages/video.scm (libvdpau)[inputs]: Replace DRI2PROTO with XORGPROTO.
* gnu/packages/xorg.scm (dri2proto)[properties]: Mark as superseded by XORGPROTO.
(xorg-server)[inputs]: Remove DRI2PROTO.
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index ffc5f33e7b..15e1e2caeb 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1936,9 +1936,9 @@ and JACK.")
     (native-inputs
      `(("pkg-config" ,pkg-config)))
     (inputs
-     `(("dri2proto" ,dri2proto)
-       ("libx11" ,libx11 "out")
-       ("libxext" ,libxext)))
+     `(("libx11" ,libx11 "out")
+       ("libxext" ,libxext)
+       ("xorgproto" ,xorgproto)))
     (home-page "https://wiki.freedesktop.org/www/Software/VDPAU/")
     (synopsis "Video Decode and Presentation API")
     (description "VDPAU is the Video Decode and Presentation API for UNIX.  It