summary refs log tree commit diff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-24 23:47:08 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-14 15:11:37 -0400
commit7faa4c2aec3d7e9ece09bb27ae7ccc5a611c5d04 (patch)
tree2abc4618eaa8f5fbc48418713175bdacf55b1c51 /gnu/packages/video.scm
parentf3b5201c86ea1b71ef4420c8ab4be7aedf1de6a5 (diff)
downloadguix-7faa4c2aec3d7e9ece09bb27ae7ccc5a611c5d04.tar.gz
gnu: ffmpeg: Update to 6.0.
* gnu/packages/video.scm (ffmpeg): Update to 6.0.
(ffmpeg-5): New variable.
* gnu/packages/gnuzilla.scm (icecat-minimal) [inputs]: Replace ffmpeg with
ffmpeg-5.
* gnu/packages/gnuzilla.scm (icedove-minimal): Likewise.
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm22
1 files changed, 17 insertions, 5 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index bf9a7c8d03..0b06d3bcef 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1579,14 +1579,14 @@ operate properly.")
 (define-public ffmpeg
   (package
     (name "ffmpeg")
-    (version "5.1.2")
+    (version "6.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://ffmpeg.org/releases/ffmpeg-"
                                   version ".tar.xz"))
               (sha256
                (base32
-                "1p7kxr0f9f9d0pyyxq9ciaj9ch2drmcw5p9jk22j111ccrnp17k1"))))
+                "10kh2f4y4isfqj4xpcqqnzk611jh89ywcjyjnq9c2jcv5p18ggjp"))))
     (build-system gnu-build-system)
     (inputs
      (append
@@ -1728,8 +1728,8 @@ operate properly.")
          "--disable-static"
 
          #$@(if (target-riscv64?)
-              '("--extra-cflags=-fPIC")
-              '())
+                '("--extra-cflags=-fPIC")
+                '())
 
          ;; Runtime cpu detection is not implemented on
          ;; MIPS, so we disable some features.
@@ -1770,9 +1770,21 @@ convert and stream audio and video.  It includes the libavcodec
 audio/video codec library.")
     (license license:gpl2+)))
 
-(define-public ffmpeg-4
+(define-public ffmpeg-5
   (package
     (inherit ffmpeg)
+    (version "5.1.2")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://ffmpeg.org/releases/ffmpeg-"
+                                  version ".tar.xz"))
+              (sha256
+               (base32
+                "1p7kxr0f9f9d0pyyxq9ciaj9ch2drmcw5p9jk22j111ccrnp17k1"))))))
+
+(define-public ffmpeg-4
+  (package
+    (inherit ffmpeg-5)
     (version "4.4.2")
     (source (origin
              (method url-fetch)