summary refs log tree commit diff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorAndrew Tropin <andrew@trop.in>2022-08-26 08:22:25 +0300
committerAndrew Tropin <andrew@trop.in>2022-08-26 08:42:46 +0300
commit4ff0ceb26462d27281eed5cf789ca4158f94409a (patch)
tree9223460615f8b7489f377445c52df92921a5f7cf /gnu/packages/video.scm
parente106b27c4b0b43631790257b7073e8d1c2cdfcc8 (diff)
downloadguix-4ff0ceb26462d27281eed5cf789ca4158f94409a.tar.gz
gnu: obs: Update to 27.2.4.
* gnu/packages/video.scm (obs): Update to 27.2.4.
[arguments]: Migrate from TRUE/FALSE to ON/OFF.
[inputs]: Add picuitls and libxkbcommon for successful build of new version,
bash-minimal for satisfying guix lint, and luajit, python for scripting
support.
[native-inputs]: Add swig for scripting support.
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm16
1 files changed, 11 insertions, 5 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 2ea575629f..556eb46df4 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -163,6 +163,7 @@
   #:use-module (gnu packages networking)
   #:use-module (gnu packages ocr)
   #:use-module (gnu packages pcre)
+  #:use-module (gnu packages pciutils)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages perl-check)
   #:use-module (gnu packages perl-web)
@@ -3320,7 +3321,7 @@ be used for realtime video capture via Linux-specific APIs.")
 (define-public obs
   (package
     (name "obs")
-    (version "27.1.3")
+    (version "27.2.4")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -3330,7 +3331,7 @@ be used for realtime video capture via Linux-specific APIs.")
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "1ndiarr3d6qihymaigf34jjml0lrgbj640fnpnffz2ysj7276q0j"))
+                "13bfzjqmvabli99yr1h0306w5lx72mbl5sxrnr46hjig1a6rw91s"))
               (patches
                (search-patches "obs-modules-location.patch"))))
     (build-system cmake-build-system)
@@ -3338,10 +3339,10 @@ be used for realtime video capture via Linux-specific APIs.")
      (list
       #:configure-flags
       #~(list (string-append "-DOBS_VERSION_OVERRIDE=" #$version)
-              "-DENABLE_UNIT_TESTS=TRUE"
+              "-DENABLE_UNIT_TESTS=ON"
               ;; Browser plugin requires cef, but it is not packaged yet.
               ;; <https://bitbucket.org/chromiumembedded/cef/src/master/>
-              "-DBUILD_BROWSER=FALSE")
+              "-DBUILD_BROWSER=OFF")
        #:phases
        #~(modify-phases %standard-phases
            (add-after 'install 'wrap-executable
@@ -3359,10 +3360,11 @@ be used for realtime video capture via Linux-specific APIs.")
             (separator #f)                         ;single entry
             (files '("share/obs/obs-plugins")))))
     (native-inputs
-     (list cmocka pkg-config))
+     (list cmocka pkg-config swig))
     (inputs
      (list
       alsa-lib
+      bash-minimal
       curl
       eudev
       ffmpeg
@@ -3373,10 +3375,14 @@ be used for realtime video capture via Linux-specific APIs.")
       jansson
       libx264
       libxcomposite
+      libxkbcommon
+      luajit
       mbedtls-apache
       mesa
+      pciutils
       pipewire-0.3
       pulseaudio
+      python
       qtbase-5
       qtsvg-5
       qtx11extras